summaryrefslogtreecommitdiff
path: root/media-libs/graphene/graphene-1.8.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /media-libs/graphene/graphene-1.8.6.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'media-libs/graphene/graphene-1.8.6.ebuild')
-rw-r--r--media-libs/graphene/graphene-1.8.6.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/media-libs/graphene/graphene-1.8.6.ebuild b/media-libs/graphene/graphene-1.8.6.ebuild
deleted file mode 100644
index e80f1568a132..000000000000
--- a/media-libs/graphene/graphene-1.8.6.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-inherit xdg-utils meson multilib-minimal python-any-r1
-
-DESCRIPTION="A thin layer of types for graphic libraries"
-HOMEPAGE="https://ebassi.github.io/graphene/"
-SRC_URI="https://github.com/ebassi/graphene/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
-IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 doc +introspection test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.30.0:2[${MULTILIB_USEDEP}]
- introspection? ( dev-libs/gobject-introspection:= )
-"
-DEPEND="${RDEPEND}"
-# Python is only needed with USE=introspection or FEATURES=test, but not bothering with conditional python_setup, as meson uses it too anyway
-BDEPEND="
- ${PYTHON_DEPS}
- doc? ( dev-util/gtk-doc
- app-text/docbook-xml-dtd:4.3 )
- virtual/pkgconfig
-"
-
-src_prepare() {
- xdg_environment_reset
- default
- # Disable installed-tests
- sed -e 's/install: true/install: false/g' -i src/tests/meson.build || die
-}
-
-multilib_src_configure() {
- # TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
- local emesonargs=(
- -Dgtk_doc=$(multilib_native_usex doc true false)
- -Dgobject_types=true
- -Dintrospection=$(multilib_native_usex introspection true false)
- -Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
- $(meson_use cpu_flags_x86_sse2 sse2)
- $(meson_use cpu_flags_arm_neon arm_neon)
- $(meson_use test tests)
- -Dbenchmarks=false
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- meson_src_test
-}
-
-multilib_src_install() {
- meson_src_install
-}