summaryrefslogtreecommitdiff
path: root/media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild')
-rw-r--r--media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild b/media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..2215a4832a52
--- /dev/null
+++ b/media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Set of GStreamer elements to ease the creation of non-linear multimedia editors"
+HOMEPAGE="http://gnonlin.sourceforge.net"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=media-libs/gstreamer-1.4.0:1.0
+ >=media-libs/gst-plugins-base-1.4.0:1.0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/gtk-doc-am-1.13
+ test? (
+ dev-libs/check
+ >=media-libs/gst-plugins-good-1.4.0:1.0 )
+" # videomixer
+
+src_configure() {
+ econf --disable-gtk-doc
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}