summaryrefslogtreecommitdiff
path: root/media-libs/gmmlib/gmmlib-22.1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-03 16:19:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-03 16:19:20 +0100
commit312456186919deebd1ea3b34b9e26b1e15ebd5b6 (patch)
tree9f41dbee43e2392f0e58ed3b9f43ce41e8d18fce /media-libs/gmmlib/gmmlib-22.1.8.ebuild
parentfe2f8d9da0555e4ed15cc203d8dd99dd60b3117e (diff)
gentoo auto-resync : 03:09:2022 - 16:19:20
Diffstat (limited to 'media-libs/gmmlib/gmmlib-22.1.8.ebuild')
-rw-r--r--media-libs/gmmlib/gmmlib-22.1.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/gmmlib/gmmlib-22.1.8.ebuild b/media-libs/gmmlib/gmmlib-22.1.8.ebuild
new file mode 100644
index 000000000000..598b7721fb10
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.1.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+
+inherit cmake
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-${P}"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0/12.1"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+ "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_TYPE="Release"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}