summaryrefslogtreecommitdiff
path: root/media-libs/glyr/glyr-1.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/glyr/glyr-1.0.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/glyr/glyr-1.0.10.ebuild')
-rw-r--r--media-libs/glyr/glyr-1.0.10.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/glyr/glyr-1.0.10.ebuild b/media-libs/glyr/glyr-1.0.10.ebuild
new file mode 100644
index 000000000000..0c0fc199cd60
--- /dev/null
+++ b/media-libs/glyr/glyr-1.0.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A music related metadata searchengine, both with commandline interface and C API"
+HOMEPAGE="https://github.com/sahib/glyr"
+SRC_URI="https://github.com/sahib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.10:2
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS README*" # CHANGELOG is obsolete in favour of git history
+
+src_prepare() {
+ sed -i \
+ -e '/GCC_ONLY_OPT.*-s/d' \
+ -e '/FLAGS/s:-Os::' \
+ -e '/FLAGS/s:-g3::' \
+ CMakeLists.txt || die
+}