summaryrefslogtreecommitdiff
path: root/media-libs/glyr/glyr-1.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /media-libs/glyr/glyr-1.0.10.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'media-libs/glyr/glyr-1.0.10.ebuild')
-rw-r--r--media-libs/glyr/glyr-1.0.10.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/media-libs/glyr/glyr-1.0.10.ebuild b/media-libs/glyr/glyr-1.0.10.ebuild
index c65461f3d9d7..deaae08241b7 100644
--- a/media-libs/glyr/glyr-1.0.10.ebuild
+++ b/media-libs/glyr/glyr-1.0.10.ebuild
@@ -1,25 +1,29 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
inherit cmake-utils
-DESCRIPTION="A music related metadata searchengine, both with commandline interface and C API"
+DESCRIPTION="Music related metadata searchengine, both with commandline interface and C API"
HOMEPAGE="https://github.com/sahib/glyr"
SRC_URI="https://github.com/sahib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 x86"
IUSE=""
-RDEPEND="dev-db/sqlite:3
+RDEPEND="
+ dev-db/sqlite:3
>=dev-libs/glib-2.10:2
- net-misc/curl"
+ net-misc/curl
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
-DOCS="AUTHORS README*" # CHANGELOG is obsolete in favour of git history
+DOCS=( AUTHORS README.textile ) # CHANGELOG is obsolete in favour of git history
src_prepare() {
cmake-utils_src_prepare