summaryrefslogtreecommitdiff
path: root/media-libs/gexiv2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-24 07:26:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-24 07:26:21 +0100
commite28a6e6eb5373071be3a09aa457f0488d753c80c (patch)
tree9ee566eff30cce9e22de0c44094909588e14027d /media-libs/gexiv2/files
parenta152c669e7ec3bb6ae13b747b985e2ece3b58b0a (diff)
gentoo auto-resync : 24:06:2023 - 07:26:21
Diffstat (limited to 'media-libs/gexiv2/files')
-rw-r--r--media-libs/gexiv2/files/0.14.1-revert-default-cpp_stdto17.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/media-libs/gexiv2/files/0.14.1-revert-default-cpp_stdto17.patch b/media-libs/gexiv2/files/0.14.1-revert-default-cpp_stdto17.patch
new file mode 100644
index 000000000000..9697e4455ba0
--- /dev/null
+++ b/media-libs/gexiv2/files/0.14.1-revert-default-cpp_stdto17.patch
@@ -0,0 +1,18 @@
+With clang 16 and libcxx this is causig build error such as:
+/usr/include/exiv2/value.hpp:54:17: error: no template named 'auto_ptr' in namespace 'std'; did you mean simply 'auto_ptr'?
+ typedef std::auto_ptr<Value> AutoPtr;
+Reverting upstream commit https://gitlab.gnome.org/GNOME/gexiv2/-/commit/2eb5c2c9ac1d36bee7089117e1f4825162a9409d
+helps solve them for now.
+
+There is on going work for exiv2-0.28
+--- a/meson.build
++++ b/meson.build
+@@ -5,7 +5,7 @@ project(
+ license: 'GPL-2.0-or-later',
+ meson_version : '>=0.51',
+ default_options : [
+- 'cpp_std=c++17'
++ 'cpp_std=c++11'
+ ]
+ )
+