summaryrefslogtreecommitdiff
path: root/media-libs/freealut/freealut-1.1.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/freealut/freealut-1.1.0-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/freealut/freealut-1.1.0-r3.ebuild')
-rw-r--r--media-libs/freealut/freealut-1.1.0-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/freealut/freealut-1.1.0-r3.ebuild b/media-libs/freealut/freealut-1.1.0-r3.ebuild
new file mode 100644
index 000000000000..dd3f5d75d8e2
--- /dev/null
+++ b/media-libs/freealut/freealut-1.1.0-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils autotools multilib-minimal
+
+DESCRIPTION="The OpenAL Utility Toolkit"
+HOMEPAGE="http://www.openal.org/"
+SRC_URI="http://connect.creativelabs.com/openal/Downloads/ALUT/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ abi_x86_32? (
+ !app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ !<=app-emulation/emul-linux-x86-sdl-20140406
+ )
+ >=media-libs/openal-1.15.1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Link against openal and pthread
+ sed -i -e 's/libalut_la_LIBADD = .*/& -lopenal -lpthread/' src/Makefile.am
+ AT_M4DIR="${S}/admin/autotools/m4" eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ dohtml doc/*
+ prune_libtool_files
+}