summaryrefslogtreecommitdiff
path: root/media-libs/flac/flac-1.4.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-05 09:19:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-05 09:19:42 +0100
commita14be3350a832e70959d0b2386bc43c3b95f82e1 (patch)
treea0bd34e3c1e8ca9489d08f257a5f29171d4bfe7f /media-libs/flac/flac-1.4.2-r1.ebuild
parent9d86a2177f8ea7e726ba388e4ee28007def4d4ac (diff)
gentoo auto-resync : 05:08:2023 - 09:19:42
Diffstat (limited to 'media-libs/flac/flac-1.4.2-r1.ebuild')
-rw-r--r--media-libs/flac/flac-1.4.2-r1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/media-libs/flac/flac-1.4.2-r1.ebuild b/media-libs/flac/flac-1.4.2-r1.ebuild
deleted file mode 100644
index 33b6ff19fad6..000000000000
--- a/media-libs/flac/flac-1.4.2-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-minimal
-
-DESCRIPTION="Free lossless audio encoder and decoder"
-HOMEPAGE="https://xiph.org/flac/"
-SRC_URI="https://downloads.xiph.org/releases/${PN}/${P}.tar.xz"
-
-LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1"
-# <libFLAC SONAME>-<libFLAC++ SONAME>
-SLOT="0/10-12"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
-IUSE="+cxx debug ogg cpu_flags_ppc_altivec cpu_flags_ppc_vsx cpu_flags_x86_avx2 cpu_flags_x86_avx static-libs"
-
-# AVX configure switch is for both AVX & AVX2
-REQUIRED_USE="
- cpu_flags_x86_avx2? ( cpu_flags_x86_avx )
-"
-
-RDEPEND="ogg? ( media-libs/libogg[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/xz-utils
- sys-devel/gettext
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.2-macro-wstrict-prototypes.patch
-)
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-doxygen-docs
- --disable-examples
- $([[ ${CHOST} == *-darwin* ]] && echo "--disable-asm-optimizations")
- $(use_enable cpu_flags_ppc_altivec altivec)
- $(use_enable cpu_flags_ppc_vsx vsx)
- $(use_enable cpu_flags_x86_avx avx)
- $(use_enable cxx cpplibs)
- $(use_enable debug)
- $(use_enable ogg)
- $(use_enable static-libs static)
-
- # cross-compile fix (bug #521446)
- # no effect if ogg support is disabled
- --with-ogg
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- if [[ ${UID} != 0 ]]; then
- emake -j1 check
- else
- ewarn "Tests will fail if ran as root, skipping."
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -type f -name '*.la' -delete || die
-}