summaryrefslogtreecommitdiff
path: root/media-libs/flac/flac-1.3.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/flac/flac-1.3.3-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/flac/flac-1.3.3-r1.ebuild')
-rw-r--r--media-libs/flac/flac-1.3.3-r1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/media-libs/flac/flac-1.3.3-r1.ebuild b/media-libs/flac/flac-1.3.3-r1.ebuild
deleted file mode 100644
index 6dfe898f30c5..000000000000
--- a/media-libs/flac/flac-1.3.3-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-minimal
-
-DESCRIPTION="free lossless audio encoder and decoder"
-HOMEPAGE="https://xiph.org/flac/"
-SRC_URI="https://downloads.xiph.org/releases/${PN}/${P}.tar.xz"
-
-LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="+cxx debug ogg cpu_flags_ppc_altivec cpu_flags_ppc_vsx cpu_flags_x86_sse static-libs"
-
-RDEPEND="ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/xz-utils
- sys-devel/gettext
- virtual/pkgconfig
- abi_x86_32? ( dev-lang/nasm )"
-
-PATCHES=( "${FILESDIR}/${P}-fix-zero-first-byte-md5sum-check.patch" )
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-doxygen-docs
- --disable-examples
- --disable-xmms-plugin
- $([[ ${CHOST} == *-darwin* ]] && echo "--disable-asm-optimizations")
- $(use_enable cpu_flags_ppc_altivec altivec)
- $(use_enable cpu_flags_ppc_vsx vsx)
- $(use_enable cpu_flags_x86_sse sse)
- $(use_enable cxx cpplibs)
- $(use_enable debug)
- $(use_enable ogg)
- $(use_enable static-libs static)
-
- # cross-compile fix (bug #521446)
- # no effect if ogg support is disabled
- --with-ogg
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- if [[ ${UID} != 0 ]]; then
- emake -j1 check
- else
- ewarn "Tests will fail if ran as root, skipping."
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -type f -name '*.la' -delete || die
-}