summaryrefslogtreecommitdiff
path: root/media-libs/flac/flac-1.3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/flac/flac-1.3.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/flac/flac-1.3.2-r1.ebuild')
-rw-r--r--media-libs/flac/flac-1.3.2-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/flac/flac-1.3.2-r1.ebuild b/media-libs/flac/flac-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..5c43c541d2c7
--- /dev/null
+++ b/media-libs/flac/flac-1.3.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="free lossless audio encoder and decoder"
+HOMEPAGE="https://xiph.org/flac/"
+SRC_URI="https://downloads.xiph.org/releases/${PN}/${P}.tar.xz"
+
+LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="altivec +cxx debug ogg cpu_flags_x86_sse static-libs"
+
+RDEPEND="ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ abi_x86_32? ( dev-lang/nasm )
+ !elibc_uclibc? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-cflags.patch
+ "${FILESDIR}"/${PN}-1.3.2-asneeded.patch
+ "${FILESDIR}"/${PN}-1.3.0-dontbuild-tests.patch
+ "${FILESDIR}"/${PN}-1.3.2-dontbuild-examples.patch
+ "${FILESDIR}"/${PN}-1.3.2-honor-htmldir.patch
+ "${FILESDIR}"/${PN}-1.3.2-fortify-sources.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-doxygen-docs
+ --disable-examples
+ --disable-xmms-plugin
+ $([[ ${CHOST} == *-darwin* ]] && echo "--disable-asm-optimizations")
+ $(use_enable altivec)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable cxx cpplibs)
+ $(use_enable debug)
+ $(use_enable ogg)
+ $(use_enable static-libs static)
+
+ # cross-compile fix (bug #521446)
+ # no effect if ogg support is disabled
+ --with-ogg
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ if [[ ${UID} != 0 ]]; then
+ emake -j1 check
+ else
+ ewarn "Tests will fail if ran as root, skipping."
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}