summaryrefslogtreecommitdiff
path: root/media-libs/fdk-aac/fdk-aac-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /media-libs/fdk-aac/fdk-aac-2.0.0.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'media-libs/fdk-aac/fdk-aac-2.0.0.ebuild')
-rw-r--r--media-libs/fdk-aac/fdk-aac-2.0.0.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/media-libs/fdk-aac/fdk-aac-2.0.0.ebuild b/media-libs/fdk-aac/fdk-aac-2.0.0.ebuild
deleted file mode 100644
index c28e667a221a..000000000000
--- a/media-libs/fdk-aac/fdk-aac-2.0.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-minimal
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mstorsjo/${PN}.git"
- [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
- inherit autotools git-r3
-else
- KEYWORDS="amd64 arm arm64 ppc ppc64 x86 ~x64-macos"
- if [[ ${PV%_p*} != ${PV} ]]; then # Gentoo snapshot
- SRC_URI="mirror://gentoo/${P}.tar.xz"
- else # Official release
- SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
- fi
-fi
-
-DESCRIPTION="Fraunhofer AAC codec library"
-HOMEPAGE="https://sourceforge.net/projects/opencore-amr/"
-LICENSE="FraunhoferFDK"
-# subslot == N where N is libfdk-aac.so.N
-SLOT="0/2"
-
-IUSE="static-libs examples"
-
-src_prepare() {
- default
- [[ ${PV} == *9999* ]] && eautoreconf
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --enable-shared
- $(use_enable static-libs static)
- $(use_enable examples example)
- )
- ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use examples; then
- mv "${ED}/usr/bin/"{,fdk-}aac-enc || die
- fi
-
- # package provides .pc files
- find "${ED}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- use examples && einfo "aac-enc was renamed to fdk-aac-enc to prevent file collision with other packages"
-}