summaryrefslogtreecommitdiff
path: root/media-libs/esdl/esdl-1.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-06 04:12:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-06 04:12:55 +0100
commit38d6f110ff1dfdd7c6f0b0baf0ed8b13191dcde3 (patch)
tree82f1a2074ab61dae5f1333408972f185457e8f30 /media-libs/esdl/esdl-1.3.1-r1.ebuild
parent0d3219165e816e09207a0e1b5b5c8ad764228615 (diff)
gentoo auto-resync : 06:07:2023 - 04:12:55
Diffstat (limited to 'media-libs/esdl/esdl-1.3.1-r1.ebuild')
-rw-r--r--media-libs/esdl/esdl-1.3.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/esdl/esdl-1.3.1-r1.ebuild b/media-libs/esdl/esdl-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..0908e7ca6aed
--- /dev/null
+++ b/media-libs/esdl/esdl-1.3.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Erlang bindings for the SDL library"
+HOMEPAGE="https://esdl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/esdl/${P}.src.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="image truetype"
+
+RDEPEND="
+ >=dev-lang/erlang-14[wxwidgets]
+ media-libs/libsdl[opengl]
+ image? ( media-libs/sdl-image )
+ truetype? ( media-libs/sdl-ttf )
+ virtual/opengl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/rebar:0"
+
+src_compile() {
+ rebar compile || die
+}
+
+src_install() {
+ ERLANG_DIR="/usr/$(get_libdir)/erlang/lib"
+ ESDL_DIR="${ERLANG_DIR}/${P}"
+
+ find -name 'Makefile*' -exec rm -f '{}' \;
+
+ insinto ${ESDL_DIR}
+ doins -r ebin c_src include priv src
+}