summaryrefslogtreecommitdiff
path: root/media-libs/embree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /media-libs/embree
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'media-libs/embree')
-rw-r--r--media-libs/embree/Manifest2
-rw-r--r--media-libs/embree/embree-3.13.2.ebuild132
2 files changed, 134 insertions, 0 deletions
diff --git a/media-libs/embree/Manifest b/media-libs/embree/Manifest
index a496b5b4c3b9..b8d7ef08927e 100644
--- a/media-libs/embree/Manifest
+++ b/media-libs/embree/Manifest
@@ -1,3 +1,5 @@
DIST embree-3.13.0.tar.gz 13708421 BLAKE2B bace1866d9d6907308d38370347d23b4edb3fe287d093acf35367be1d4548d1df064ed9d46ef928f17af99e335d5fcd7b7285a2bd95707361440547544782080 SHA512 3fc4f00151cb9558810c643bf77f3135465d65c4523e08d5289a0fdcb18d4c63a8e805647e4ce208556c4679d44373d817761c1003b1e9dc65a39d5ebf17926f
+DIST embree-3.13.2.tar.gz 13716621 BLAKE2B 8fd770ea9984a9f5b532f114c7901a67105f95c98a1bad45ed9dc2e312062e22aee26d54bd54ac3c9593fed14d34b03903ac186516682890cfaf9e0714743cce SHA512 9e4912f52c503d8d1fe0c3c81bf8108f1af044bf08d76111e4c1ab434c6a38d33bae9aacfd60c874da76bcc2f909ad1f3f171d458adb7973644cdbfd3693dc0f
EBUILD embree-3.13.0-r2.ebuild 3671 BLAKE2B f9833656184addff84fcd49024e8ad82bbb871de8ae5b82a19bf1baf9b2cdbb871b13f8919e6046f3aaaa043aabe8867b8ba17ab121c4b3cf1fc9aafe1b28428 SHA512 a5e7a50b44142baafadfd5157fb6af32a6e702688efa9ea72aa1c8c36fdbc8bf752cb9105d9e2e9f696ae6e8aa833f2a78c47e663d60821dd34e2c05acdb6c8a
+EBUILD embree-3.13.2.ebuild 3775 BLAKE2B ecfd7e1629e2250ac08d4e597e75c2edf9ff32f27180d9108907a31e4915a784b3d5a37f7818304ad205ca1aede6a73792c84ac1391b31a2735c4e13c752efe8 SHA512 edbefc1ee4277f3cf8f2dbb26f5740ae634cfe01b84bc65073b62bbd74df49789e134dd8d76c2e2ee85f7256bb935bce8168840c42b5019b25eaacdecadfdf9c
MISC metadata.xml 1705 BLAKE2B 2785c8b8752e5730e014ce6edfdd1702a20565ab12c9ebee14c3cf603e267a63360eaa0428afb9e178091edad40fe82ea55e2a872339da744113e480b4eda6c2 SHA512 ebfa1a6d3f8a8fe6acc0cc06f54ad62efb86942b55e985542a049fde421663adddcffe2a78c7309774df9bbc714a2bb11dad73c94b89bf2d1cdf56b69d334f59
diff --git a/media-libs/embree/embree-3.13.2.ebuild b/media-libs/embree/embree-3.13.2.ebuild
new file mode 100644
index 000000000000..94efef93e9b9
--- /dev/null
+++ b/media-libs/embree/embree-3.13.2.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic linux-info toolchain-funcs
+
+DESCRIPTION="Collection of high-performance ray tracing kernels"
+HOMEPAGE="https://github.com/embree/embree"
+SRC_URI="https://github.com/embree/embree/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+X86_CPU_FLAGS=( sse2:sse2 sse4_2:sse4_2 avx:avx avx2:avx2 avx512dq:avx512dq )
+CPU_FLAGS=( cpu_flags_arm_neon ${X86_CPU_FLAGS[@]/#/cpu_flags_x86_} )
+IUSE="+compact-polys ispc +raymask ssp +tbb tutorial static-libs ${CPU_FLAGS[@]%:*}"
+# Let's be explicit here even though we could simplify it.
+REQUIRED_USE="amd64? ( cpu_flags_x86_sse2 ) x86? ( cpu_flags_x86_sse2 )"
+
+RESTRICT="mirror"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=media-libs/glfw-3.2.1
+ virtual/opengl
+ ispc? ( dev-lang/ispc )
+ tbb? ( dev-cpp/tbb:= )
+ tutorial? (
+ >=media-libs/libpng-1.6.34:0=
+ >=media-libs/openimageio-1.8.7:0=
+ virtual/jpeg:0
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md README.md readme.pdf )
+
+pkg_setup() {
+ CONFIG_CHECK="~TRANSPARENT_HUGEPAGE"
+ WARNING_TRANSPARENT_HUGEPAGE="Not enabling Transparent Hugepages (CONFIG_TRANSPARENT_HUGEPAGE) will impact rendering performance."
+
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # disable RPM package building
+ sed -e 's|CPACK_RPM_PACKAGE_RELEASE 1|CPACK_RPM_PACKAGE_RELEASE 0|' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ # NOTE: You can make embree accept custom CXXFLAGS by turning off
+ # EMBREE_IGNORE_CMAKE_CXX_FLAGS. However, the linking will fail if you use
+ # any "march" compile flags. This is because embree builds modules for the
+ # different supported ISAs and picks the correct one at runtime.
+ # "march" will pull in cpu instructions that shouldn't be in specific modules
+ # and it fails to link properly.
+ # https://github.com/embree/embree/issues/115
+
+ filter-flags -march=*
+
+ local mycmakeargs=(
+ # Currently Intel only host their test files on their internal network.
+ # So it seems like users can't easily get a hold of these and do
+ # regression testing on their own.
+ -DBUILD_TESTING:BOOL=OFF
+ -DCMAKE_SKIP_INSTALL_RPATH:BOOL=ON
+
+ # default
+ -DEMBREE_BACKFACE_CULLING=OFF
+ -DEMBREE_COMPACT_POLYS=$(usex compact-polys)
+
+ # default
+ -DEMBREE_FILTER_FUNCTION=ON
+ # default
+ -DEMBREE_GEOMETRY_CURVE=ON
+ # default
+ -DEMBREE_GEOMETRY_GRID=ON
+ # default
+ -DEMBREE_GEOMETRY_INSTANCE=ON
+ # default
+ -DEMBREE_GEOMETRY_POINT=ON
+ # default
+ -DEMBREE_GEOMETRY_QUAD=ON
+ # default
+ -DEMBREE_GEOMETRY_SUBDIVISION=ON
+ # default
+ -DEMBREE_GEOMETRY_TRIANGLE=ON
+ # default
+ -DEMBREE_GEOMETRY_USER=ON
+ # default
+ -DEMBREE_IGNORE_CMAKE_CXX_FLAGS=OFF
+ # default
+ -DEMBREE_IGNORE_INVALID_RAYS=OFF
+
+ # Set to NONE so we can manually switch on ISAs below
+ -DEMBREE_MAX_ISA:STRING="NONE"
+ -DEMBREE_ISA_AVX=$(usex cpu_flags_x86_avx)
+ -DEMBREE_ISA_AVX2=$(usex cpu_flags_x86_avx2)
+ -DEMBREE_ISA_AVX512=$(usex cpu_flags_x86_avx512dq)
+ -DEMBREE_ISA_NEON=$(usex cpu_flags_arm_neon)
+ -DEMBREE_ISA_SSE2=$(usex cpu_flags_x86_sse2)
+ -DEMBREE_ISA_SSE42=$(usex cpu_flags_x86_sse4_2)
+ -DEMBREE_ISPC_SUPPORT=$(usex ispc)
+ -DEMBREE_RAY_MASK=$(usex raymask)
+ # default
+ -DEMBREE_RAY_PACKETS=ON
+ -DEMBREE_STACK_PROTECTOR=$(usex ssp)
+ -DEMBREE_STATIC_LIB=$(usex static-libs)
+ -DEMBREE_STAT_COUNTERS=OFF
+ -DEMBREE_TASKING_SYSTEM:STRING=$(usex tbb "TBB" "INTERNAL")
+ -DEMBREE_TUTORIALS=$(usex tutorial))
+
+ # Disable asserts
+ append-cppflags -DNDEBUG
+
+ if use tutorial; then
+ mycmakeargs+=(
+ -DEMBREE_ISPC_ADDRESSING:STRING="64"
+ -DEMBREE_TUTORIALS_LIBJPEG=ON
+ -DEMBREE_TUTORIALS_LIBPNG=ON
+ -DEMBREE_TUTORIALS_OPENIMAGEIO=ON
+ )
+ fi
+
+ cmake_src_configure
+}