summaryrefslogtreecommitdiff
path: root/media-libs/embree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /media-libs/embree
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'media-libs/embree')
-rw-r--r--media-libs/embree/Manifest4
-rw-r--r--media-libs/embree/embree-3.13.0-r1.ebuild (renamed from media-libs/embree/embree-3.13.0.ebuild)20
-rw-r--r--media-libs/embree/metadata.xml7
3 files changed, 19 insertions, 12 deletions
diff --git a/media-libs/embree/Manifest b/media-libs/embree/Manifest
index 1e82bbc6dba3..581da6c2f229 100644
--- a/media-libs/embree/Manifest
+++ b/media-libs/embree/Manifest
@@ -1,3 +1,3 @@
DIST embree-3.13.0.tar.gz 13708421 BLAKE2B bace1866d9d6907308d38370347d23b4edb3fe287d093acf35367be1d4548d1df064ed9d46ef928f17af99e335d5fcd7b7285a2bd95707361440547544782080 SHA512 3fc4f00151cb9558810c643bf77f3135465d65c4523e08d5289a0fdcb18d4c63a8e805647e4ce208556c4679d44373d817761c1003b1e9dc65a39d5ebf17926f
-EBUILD embree-3.13.0.ebuild 3465 BLAKE2B b5e4e31760538f51c50ba1526ee29eebdab8c5ee720267ec65457d31112ac481c45fc76413460bb327975a79e7c89023b8d3c40bd14855e994d6bf3aabbeba11 SHA512 a9fee50a34340c78b0c21c6128fcb53f1f59e351557ede13bea0e9f2b54641b639911b2850c707f2248357bbcc54bb00b712af07263f17f7f2276a9bbe4d42a2
-MISC metadata.xml 1613 BLAKE2B 916b6146240c4615a8baa634e74b5548bc9bb3951754e29fcc1c7bbde5e0bf149b78aa188ae90f96e6f5635c849bdcddb53c71207f5404f3b13f919824026129 SHA512 0b12bb93ffa005da30ee1c7106d2adffd82fafe66d5fded8b199ab77392773db03cd88e380a2b861bcf502275deb1e2467c7637b7548356c8487387b532cb7e1
+EBUILD embree-3.13.0-r1.ebuild 3651 BLAKE2B 65fa6bda49493f6eef10eb47ebbff48aa04a2d0215db0c3d3b804bf463100c3f5d8eaab8ae2f1ef5957ac503d97ea425d51530b0829d4e20be8efa978336b850 SHA512 9dcfcc5703680ca291495205dd66f911d4c708e5cbf665c08579a6afc63de43074bc092c1bcd5565ed3a1fdb02ad3089031824da4b735684eb44ee393c9baa4f
+MISC metadata.xml 1704 BLAKE2B badfdc7f376750baf3cf4b6857651f0ef86c90a6acd1046694e49b2d641e53d6b31855a7326b66cc7f5473dd747da26c202d8433adb5ab7380269578ee46d6b1 SHA512 3bbe4c5d05bc4d5d7fde27bbd51ed9292fed45c03e72a6bdcbf163bfdadd3738249ac76c292bf4751e19b248dd4438e49fa5af0b78221d8cb0da2078bf0d5a87
diff --git a/media-libs/embree/embree-3.13.0.ebuild b/media-libs/embree/embree-3.13.0-r1.ebuild
index 7fb5564741fa..f77d5a1eb87c 100644
--- a/media-libs/embree/embree-3.13.0.ebuild
+++ b/media-libs/embree/embree-3.13.0-r1.ebuild
@@ -7,29 +7,32 @@ inherit cmake flag-o-matic linux-info toolchain-funcs
DESCRIPTION="Collection of high-performance ray tracing kernels"
HOMEPAGE="https://github.com/embree/embree"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/embree/embree/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
SLOT="3"
+KEYWORDS="~amd64 ~x86"
X86_CPU_FLAGS=( sse2:sse2 sse4_2:sse4_2 avx:avx avx2:avx2 avx512dq:avx512dq )
CPU_FLAGS=( ${X86_CPU_FLAGS[@]/#/cpu_flags_x86_} )
IUSE="+compact-polys ispc +raymask ssp +tbb tutorial static-libs ${CPU_FLAGS[@]%:*}"
+RESTRICT="mirror"
+
BDEPEND="
virtual/pkgconfig
"
RDEPEND="
- ispc? ( dev-lang/ispc )
>=media-libs/glfw-3.2.1
+ virtual/opengl
+ ispc? ( dev-lang/ispc )
tbb? ( dev-cpp/tbb )
tutorial? (
>=media-libs/libpng-1.6.34:0=
- >=media-libs/openimageio-1.8.7
+ >=media-libs/openimageio-1.8.7:0=
virtual/jpeg:0
)
- virtual/opengl
"
DEPEND="${RDEPEND}"
-RESTRICT="mirror"
+
DOCS=( CHANGELOG.md README.md readme.pdf )
pkg_setup() {
@@ -62,6 +65,9 @@ src_configure() {
filter-flags -march=*
local mycmakeargs=(
+ # Currently Intel only host their test files on their internal network.
+ # So it seems like users can't easily get a hold of these and do
+ # regression testing on their own.
-DBUILD_TESTING:BOOL=OFF
-DCMAKE_SKIP_INSTALL_RPATH:BOOL=ON
-DEMBREE_BACKFACE_CULLING=OFF # default
@@ -93,7 +99,7 @@ src_configure() {
-DEMBREE_TUTORIALS=$(usex tutorial) )
# Disable asserts
- append-flags -DNDEBUG
+ append-cppflags -DNDEBUG
if use tutorial; then
mycmakeargs+=(
diff --git a/media-libs/embree/metadata.xml b/media-libs/embree/metadata.xml
index 9fb89375a782..dcaede1dd583 100644
--- a/media-libs/embree/metadata.xml
+++ b/media-libs/embree/metadata.xml
@@ -20,15 +20,16 @@
<flag restrict="&gt;=media-libs/embree-3.12.2" name="compact-polys">
Enables double indexed poly layout.
</flag>
- <flag restrict="&gt;=media-libs/embree-3.12.2" name="ssp">
- When enabled, Embree compiles with stack protection against return address overrides.
- </flag>
<flag restrict="&gt;=media-libs/embree-3.12.2" name="ispc">
Build Embree with support for ISPC applications.
</flag>
<flag restrict="&gt;=media-libs/embree-3.12.2" name="raymask">
Enables ray mask support.
</flag>
+ <flag restrict="&gt;=media-libs/embree-3.12.2" name="ssp">
+ When enabled, Embree compiles with stack protection against return address overrides.
+ Stack protection will wield a minor performance decrease in return for higher security.
+ </flag>
<flag restrict="&gt;=media-libs/embree-3.12.2" name="tbb">
Use TBB instead of the built-in Embree tasking system.
</flag>