summaryrefslogtreecommitdiff
path: root/media-libs/dav1d
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /media-libs/dav1d
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'media-libs/dav1d')
-rw-r--r--media-libs/dav1d/Manifest6
-rw-r--r--media-libs/dav1d/dav1d-0.1.0.ebuild58
-rw-r--r--media-libs/dav1d/dav1d-9999.ebuild4
-rw-r--r--media-libs/dav1d/metadata.xml4
4 files changed, 66 insertions, 6 deletions
diff --git a/media-libs/dav1d/Manifest b/media-libs/dav1d/Manifest
index fe0277b6729e..2edc8a7d5ee2 100644
--- a/media-libs/dav1d/Manifest
+++ b/media-libs/dav1d/Manifest
@@ -1,2 +1,4 @@
-EBUILD dav1d-9999.ebuild 1131 BLAKE2B 25235518b5199a21871de09f885490df749dd10c2fdb64dd52935a4d0a927eb5ff8b3bedc75ce9abc5f0537de5ccd00bbbd8263df35708f51e2e96fa21d4ea35 SHA512 c1b8af3e802d99af531c6a74e203c22dfe5ab434af292c86f985cb6758a51c79dc63f18bfbe105c18b888b5c7fdc677a2968773a05ac09dec924a56417d736e4
-MISC metadata.xml 529 BLAKE2B 5f4963950bd6dffb3408c3fa16a6f8f48c241fde43312ada259db26454f56cc0076efee69d7dfe1f772e4b9815aa178f889f87a5136697c16b6aec1b5ba8afde SHA512 41e9eb4451c973a11cd9d4601fc74b1b1fafc473bdfff8d041a4f7660374be717396bda14b188bf2183b4da713c0bfed2e0ed3f7346af382e498926d9295fff7
+DIST dav1d-0.1.0.tar.bz2 351745 BLAKE2B 302680ddfdc8d5a3eff90541ed156e820c3322bfb93316da1b2deabeac40062103af19e99dfa810678e62ad668c4aed944ac9bf8160afb301b100063919ed2a1 SHA512 5893ad40af7c4f5c3678ecc604ad360b5d1cd3fadaa16f7183d638745097fed091aeb3456540db61a2f4f0fc8bb93f2a20f428c76a7976d3fd186cc8b8baed53
+EBUILD dav1d-0.1.0.ebuild 1128 BLAKE2B 20202e1f79289bf576003933bfae0e417974df92f810c2a6ed873e1143af297c2af37918fed3ead030206a4d96fe22722a943b11f2b66a8e1dce210256f7f2c1 SHA512 d25a735d98e03391640d290669a69fe225d28ec3a8a3a1137919d4cd47e97e11f03e1c30f0f2123153b4c0a34f6e8539da94b100a05c0c42e98247b1aabb2d38
+EBUILD dav1d-9999.ebuild 1128 BLAKE2B 20202e1f79289bf576003933bfae0e417974df92f810c2a6ed873e1143af297c2af37918fed3ead030206a4d96fe22722a943b11f2b66a8e1dce210256f7f2c1 SHA512 d25a735d98e03391640d290669a69fe225d28ec3a8a3a1137919d4cd47e97e11f03e1c30f0f2123153b4c0a34f6e8539da94b100a05c0c42e98247b1aabb2d38
+MISC metadata.xml 536 BLAKE2B 40ec2224aed078ad4748d3182defb6813cdd34a614d40db2fbbbeb8b63e24a59ba1cbe9d458fec17516c328a89f77927d9fbeb9a1e4a2b8c296b7de7235b1af4 SHA512 74e6595ce441bb313364f375a8afa9b2a0179f350e30d075ecf99e058874450e15f4005a0712e20a4feb047d57799dffacb3903af00a3c5a8d059f7025e49de6
diff --git a/media-libs/dav1d/dav1d-0.1.0.ebuild b/media-libs/dav1d/dav1d-0.1.0.ebuild
new file mode 100644
index 000000000000..8b2a1f361334
--- /dev/null
+++ b/media-libs/dav1d/dav1d-0.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+SCM=""
+if [[ "${PV}" == "9999" ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
+fi
+
+inherit ${SCM} meson ninja-utils multilib-minimal
+
+DESCRIPTION="dav1d is an AV1 Decoder :)"
+HOMEPAGE="https://code.videolan.org/videolan/dav1d"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="+8bit +10bit +asm"
+
+ASM_DEPEND=">=dev-lang/nasm-2.13"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ asm? (
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )
+ )"
+
+DOCS=( README.md doc/PATENTS )
+
+multilib_src_configure() {
+ local -a bits=()
+ use 8bit && bits+=( 8 )
+ use 10bit && bits+=( 16 )
+
+ if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
+ build_asm=false
+ else
+ build_asm=$(usex asm true false)
+ fi
+
+ local emesonargs=(
+ -D bitdepths=$(IFS=,; echo "${bits[*]}")
+ -D build_asm=$build_asm
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}
diff --git a/media-libs/dav1d/dav1d-9999.ebuild b/media-libs/dav1d/dav1d-9999.ebuild
index c5eab1165a34..8b2a1f361334 100644
--- a/media-libs/dav1d/dav1d-9999.ebuild
+++ b/media-libs/dav1d/dav1d-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,7 +34,7 @@ DOCS=( README.md doc/PATENTS )
multilib_src_configure() {
local -a bits=()
use 8bit && bits+=( 8 )
- use 10bit && bits+=( 10 )
+ use 10bit && bits+=( 16 )
if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
build_asm=false
diff --git a/media-libs/dav1d/metadata.xml b/media-libs/dav1d/metadata.xml
index 96b9f2cd5594..112a2f9c98f1 100644
--- a/media-libs/dav1d/metadata.xml
+++ b/media-libs/dav1d/metadata.xml
@@ -6,8 +6,8 @@
</maintainer>
<use>
<flag name="8bit">Add support for decoding 8-bit AV1.</flag>
- <flag name="10bit">Add support for building 10-bit AV1.</flag>
- <flag name="asm">Enable custom x86 assembly for faster decoding.</flag>
+ <flag name="10bit">Add support for building 10-bit and 12-bit AV1.</flag>
+ <flag name="asm">Enable custom assembly for faster decoding.</flag>
</use>
<upstream>
<bugs-to>https://code.videolan.org/videolan/dav1d/issues</bugs-to>