summaryrefslogtreecommitdiff
path: root/media-libs/ctl/ctl-1.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/ctl/ctl-1.5.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/ctl/ctl-1.5.2.ebuild')
-rw-r--r--media-libs/ctl/ctl-1.5.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/ctl/ctl-1.5.2.ebuild b/media-libs/ctl/ctl-1.5.2.ebuild
new file mode 100644
index 000000000000..ada618aa9569
--- /dev/null
+++ b/media-libs/ctl/ctl-1.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="AMPAS' Color Transformation Language"
+HOMEPAGE="https://github.com/ampas/CTL"
+SRC_URI="${HOMEPAGE}/archive/ctl-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AMPAS"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="media-libs/ilmbase:=
+ media-libs/openexr:=
+ media-libs/tiff:=
+ !media-libs/openexr_ctl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/CTL-ctl-${PV}"
+
+PATCHES=( "${FILESDIR}/${P}-Use-GNUInstallDirs-and-fix-PkgConfig-files.patch" )
+
+mycmakeargs=( -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}" )