summaryrefslogtreecommitdiff
path: root/media-libs/codec2/codec2-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-05 11:30:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-05 11:30:40 +0100
commit3023707d355581e5dc6945aa9c8f4d59e508a8b5 (patch)
tree5bf569d557ba145002d922f72eadde17410572d4 /media-libs/codec2/codec2-1.1.0.ebuild
parent4e777c0133d093c9c8b992c92e0f244e2055bf71 (diff)
gentoo auto-resync : 05:05:2023 - 11:30:40
Diffstat (limited to 'media-libs/codec2/codec2-1.1.0.ebuild')
-rw-r--r--media-libs/codec2/codec2-1.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/codec2/codec2-1.1.0.ebuild b/media-libs/codec2/codec2-1.1.0.ebuild
new file mode 100644
index 000000000000..7b8c5a0bc64b
--- /dev/null
+++ b/media-libs/codec2/codec2-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Low bit rate speech codec"
+HOMEPAGE="https://freedv.org/ https://www.rowetel.com/?page_id=452 https://github.com/drowe67/codec2"
+SRC_URI="https://github.com/drowe67/codec2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples test"
+
+# Not yet passing, but infrastructure added to run
+# Needs Octave dependencies like "signal"?
+# https://github.com/drowe67/codec2/commit/9a129f1b3ad12ecbf3df7f4460f496ee11e49c08#diff-b335630551682c19a781afebcf4d07bf978fb1f8ac04c6bf87428ed5106870f5R155
+RESTRICT="test"
+
+#BDEPEND="test? ( sci-mathematics/octave )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ # tries to look for octave during configure phase if unit
+ # tests are turned on and bails out during configure if it
+ # cannot find it. since we have test dependency disabled
+ # for now, don't flip this configure flag
+ # -DUNITTEST=$(usex test) # reenable once tests wired up
+ -DUNITTEST=OFF
+ -DINSTALL_EXAMPLES=$(usex examples)
+ )
+
+ cmake_src_configure
+}