summaryrefslogtreecommitdiff
path: root/media-libs/cimg/cimg-3.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
commitf356af92b88d56b78588e81310493d4f5a2f6d18 (patch)
tree0326fb33173ae3d096527af28f85685515533fbb /media-libs/cimg/cimg-3.2.4.ebuild
parent560358ad7081e6bb2a4e097d4c442b0bab626163 (diff)
gentoo auto-resync : 10:05:2023 - 23:44:41
Diffstat (limited to 'media-libs/cimg/cimg-3.2.4.ebuild')
-rw-r--r--media-libs/cimg/cimg-3.2.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/cimg/cimg-3.2.4.ebuild b/media-libs/cimg/cimg-3.2.4.ebuild
new file mode 100644
index 000000000000..5ea343966cc1
--- /dev/null
+++ b/media-libs/cimg/cimg-3.2.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="C++ template image processing toolkit"
+HOMEPAGE="https://cimg.eu/ https://github.com/dtschump/CImg"
+SRC_URI="https://github.com/dtschump/CImg/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/CImg-v.${PV}"
+
+LICENSE="CeCILL-2 CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+src_install() {
+ doheader CImg.h
+ dodoc README.txt
+
+ use doc && dodoc -r html
+ if use examples; then
+ dodoc -r examples
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}