summaryrefslogtreecommitdiff
path: root/media-libs/cimg/cimg-1.7.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/cimg/cimg-1.7.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/cimg/cimg-1.7.8.ebuild')
-rw-r--r--media-libs/cimg/cimg-1.7.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-libs/cimg/cimg-1.7.8.ebuild b/media-libs/cimg/cimg-1.7.8.ebuild
new file mode 100644
index 000000000000..5f02f816fae4
--- /dev/null
+++ b/media-libs/cimg/cimg-1.7.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV=${PV//./}
+MY_P="CImg-v.${MY_PV}"
+
+DESCRIPTION="C++ template image processing toolkit"
+HOMEPAGE="http://cimg.eu/ https://github.com/dtschump/CImg"
+SRC_URI="https://github.com/dtschump/CImg/archive/v.${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-2 CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodoc README.txt
+ doheader CImg.h
+ use doc && dodoc -r html
+}