summaryrefslogtreecommitdiff
path: root/media-libs/celt/celt-0.11.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/celt/celt-0.11.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/celt/celt-0.11.1-r1.ebuild')
-rw-r--r--media-libs/celt/celt-0.11.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/celt/celt-0.11.1-r1.ebuild b/media-libs/celt/celt-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..dc9c81bceba2
--- /dev/null
+++ b/media-libs/celt/celt-0.11.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="CELT is a very low delay audio codec designed for high-quality communications"
+HOMEPAGE="http://www.celt-codec.org/"
+SRC_URI="http://downloads.us.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ~ia64 ppc ~ppc64 ~sparc x86"
+IUSE="ogg static-libs"
+
+DEPEND="ogg? ( media-libs/libogg )"
+RDEPEND="${DEPEND}"
+DOCS=( README TODO )
+
+multilib_src_configure() {
+ # ogg is for the binaries
+ local myconf="--without-ogg"
+ multilib_is_native_abi && myconf="$(use_with ogg ogg /usr)"
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+}