summaryrefslogtreecommitdiff
path: root/media-libs/ccaudio2/ccaudio2-2.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/ccaudio2/ccaudio2-2.1.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/ccaudio2/ccaudio2-2.1.3.ebuild')
-rw-r--r--media-libs/ccaudio2/ccaudio2-2.1.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/ccaudio2/ccaudio2-2.1.3.ebuild b/media-libs/ccaudio2/ccaudio2-2.1.3.ebuild
new file mode 100644
index 000000000000..1c87c2187e6b
--- /dev/null
+++ b/media-libs/ccaudio2/ccaudio2-2.1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF="1"
+
+inherit autotools-utils
+
+DESCRIPTION="C++ class framework for manipulating audio data"
+HOMEPAGE="https://www.gnu.org/software/ccaudio"
+SRC_URI="mirror://gnu/ccaudio/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug static-libs +speex gsm"
+
+RDEPEND="dev-libs/ucommon
+ gsm? ( media-sound/gsm )
+ speex? ( media-libs/speex )
+ "
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ "
+
+PATCHES=("${FILESDIR}"/disable_gsm_automagic.patch)
+DOCS=(AUTHORS ChangeLog INSTALL NEWS README SUPPORT THANKS TODO)
+
+REQUIRED_USE="^^ ( gsm speex )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable speex)
+ $(use_enable gsm)
+ )
+ autotools-utils_src_configure
+}