summaryrefslogtreecommitdiff
path: root/media-libs/bcg729/bcg729-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /media-libs/bcg729/bcg729-1.1.1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'media-libs/bcg729/bcg729-1.1.1.ebuild')
-rw-r--r--media-libs/bcg729/bcg729-1.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/bcg729/bcg729-1.1.1.ebuild b/media-libs/bcg729/bcg729-1.1.1.ebuild
new file mode 100644
index 000000000000..4ff2047c3db0
--- /dev/null
+++ b/media-libs/bcg729/bcg729-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="encoder and decoder of the ITU G729 Annex A/B speech codec"
+HOMEPAGE="https://github.com/BelledonneCommunications/bcg729"
+SRC_URI="https://github.com/BelledonneCommunications/bcg729/archive/${PV/_/-}.tar.gz \
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="!media-plugins/mediastreamer-bcg729"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_STATIC=no
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ find "${ED}" -name '*.la' -delete || die
+}