summaryrefslogtreecommitdiff
path: root/media-libs/bcg729/bcg729-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /media-libs/bcg729/bcg729-1.1.1.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'media-libs/bcg729/bcg729-1.1.1.ebuild')
-rw-r--r--media-libs/bcg729/bcg729-1.1.1.ebuild28
1 files changed, 24 insertions, 4 deletions
diff --git a/media-libs/bcg729/bcg729-1.1.1.ebuild b/media-libs/bcg729/bcg729-1.1.1.ebuild
index e724197e7cff..cf638a772cfc 100644
--- a/media-libs/bcg729/bcg729-1.1.1.ebuild
+++ b/media-libs/bcg729/bcg729-1.1.1.ebuild
@@ -1,29 +1,49 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake
+TEST_SUFFIX="tests-20210101"
DESCRIPTION="encoder and decoder of the ITU G729 Annex A/B speech codec"
HOMEPAGE="https://github.com/BelledonneCommunications/bcg729"
-SRC_URI="https://github.com/BelledonneCommunications/bcg729/archive/${PV/_/-}.tar.gz \
- -> ${P}.tar.gz"
+SRC_URI="https://github.com/BelledonneCommunications/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" test? ( http://www.belledonne-communications.com/bc-downloads/${PN}-patterns.zip -> ${PN}-${TEST_SUFFIX}.zip )"
S="${WORKDIR}/${P/_/-}"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ppc64 ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ppc64 x86"
+IUSE="test"
+RESTRICT="test"
+# Not all passing yet
+# TODO: Report upstream
+#RESTRICT="!test? ( test )"
+BDEPEND="test? ( app-arch/unzip )"
RDEPEND="!media-plugins/mediastreamer-bcg729"
+src_prepare() {
+ sed -i -e 's/-Werror //' CMakeLists.txt || die
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_STATIC=no
+ -DENABLE_TESTS=$(usex test)
)
cmake_src_configure
}
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+ mv "${WORKDIR}/patterns" "${BUILD_DIR}/test/" || die
+
+ ./testCampaignAll || die
+}
+
src_install() {
cmake_src_install
find "${ED}" -name '*.la' -delete || die