summaryrefslogtreecommitdiff
path: root/media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-09 09:14:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-09 09:14:02 +0000
commitb9ef7cab6264f1838672efbbcb4ba3b3abd5323f (patch)
tree38e677f4a13244ca8ed29a815a0a62f943b430d4 /media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild
parentd37b97a25b8b10f748eead6574b01f893f140b01 (diff)
gentoo resync : 09.12.2017
Diffstat (limited to 'media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild')
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild
index 8ec82b2f23d5..65575efc73a0 100644
--- a/media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild
+++ b/media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
PYTHON_COMPAT=( python2_7 )
@@ -13,7 +13,7 @@ HOMEPAGE="http://fixounet.free.fr/avidemux"
# Multiple licenses because of all the bundled stuff.
LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
SLOT="2.6"
-IUSE="aac aften a52 alsa amr dcaenc debug dts fdk fontconfig fribidi jack lame libsamplerate cpu_flags_x86_mmx opengl nvenc opus oss pulseaudio qt4 qt5 vorbis truetype twolame xv xvid x264 x265 vdpau vpx"
+IUSE="aac aften a52 alsa amr dcaenc debug dts fdk fontconfig fribidi jack lame libsamplerate cpu_flags_x86_mmx opengl nvenc opus oss pulseaudio qt5 vorbis truetype twolame xv xvid x264 x265 vdpau vpx"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
if [[ ${PV} == *9999* ]] ; then
@@ -28,9 +28,9 @@ else
KEYWORDS="~amd64 ~x86"
fi
-RDEPEND="
+RDEPEND="${PYTHON_DEPS}
~media-libs/avidemux-core-${PV}:${SLOT}[vdpau?]
- ~media-video/avidemux-${PV}:${SLOT}[opengl?,qt4?,qt5?]
+ ~media-video/avidemux-${PV}:${SLOT}[opengl?,qt5?]
>=dev-lang/spidermonkey-1.5-r2:0=
dev-libs/libxml2:2
media-libs/a52dec:0
@@ -71,7 +71,6 @@ RDEPEND="
xvid? ( media-libs/xvid:0 )
vorbis? ( media-libs/libvorbis:0 )
vpx? ( media-libs/libvpx:0 )
- ${PYTHON_DEPS}
"
DEPEND="${RDEPEND}
oss? ( virtual/os-headers:0 )"
@@ -88,7 +87,6 @@ src_prepare() {
processes="buildPluginsCommon:avidemux_plugins
buildPluginsCLI:avidemux_plugins"
- use qt4 && processes+=" buildPluginsQt4:avidemux_plugins"
for process in ${processes} ; do
CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
@@ -126,7 +124,7 @@ src_configure() {
-DOPUS="$(usex opus)"
-DOSS="$(usex oss)"
-DPULSEAUDIOSIMPLE="$(usex pulseaudio)"
- -DQT4="$(usex qt4)"
+ -DQT4=OFF
-DFREETYPE2="$(usex truetype)"
-DTWOLAME="$(usex twolame)"
-DX264="$(usex x264)"