summaryrefslogtreecommitdiff
path: root/media-libs/assimp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/assimp/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/assimp/files')
-rw-r--r--media-libs/assimp/files/findassimp-3.3.1.patch25
-rw-r--r--media-libs/assimp/files/findassimp-4.0.0.patch25
-rw-r--r--media-libs/assimp/files/findassimp.patch18
-rw-r--r--media-libs/assimp/files/test-cmakelists.patch35
4 files changed, 103 insertions, 0 deletions
diff --git a/media-libs/assimp/files/findassimp-3.3.1.patch b/media-libs/assimp/files/findassimp-3.3.1.patch
new file mode 100644
index 000000000000..0f36fafb0152
--- /dev/null
+++ b/media-libs/assimp/files/findassimp-3.3.1.patch
@@ -0,0 +1,25 @@
+--- a/cmake-modules/Findassimp.cmake 2016-09-26 07:52:09.719727490 +0200
++++ b/cmake-modules/Findassimp.cmake 2016-09-26 07:52:28.509727838 +0200
+@@ -55,13 +55,13 @@
+ find_path(
+ assimp_INCLUDE_DIRS
+ NAMES postprocess.h scene.h version.h config.h cimport.h
+- PATHS /usr/local/include/
++ PATHS /usr/include/
+ )
+
+ find_library(
+ assimp_LIBRARIES
+ NAMES assimp
+- PATHS /usr/local/lib/
++ PATHS /usr/lib/
+ )
+
+ if (assimp_INCLUDE_DIRS AND assimp_LIBRARIES)
+@@ -78,4 +78,4 @@
+ endif (assimp_FIND_REQUIRED)
+ endif (assimp_FOUND)
+
+-endif(WIN32)
+\ Brak znaku nowej linii na końcu pliku
++endif(WIN32)
diff --git a/media-libs/assimp/files/findassimp-4.0.0.patch b/media-libs/assimp/files/findassimp-4.0.0.patch
new file mode 100644
index 000000000000..2fbaa73a8500
--- /dev/null
+++ b/media-libs/assimp/files/findassimp-4.0.0.patch
@@ -0,0 +1,25 @@
+--- a/cmake-modules/Findassimp.cmake 2017-07-24 08:21:12.436647541 +0200
++++ b/cmake-modules/Findassimp.cmake 2017-07-24 08:21:30.139980768 +0200
+@@ -55,13 +55,13 @@
+ find_path(
+ assimp_INCLUDE_DIRS
+ NAMES postprocess.h scene.h version.h config.h cimport.h
+- PATHS /usr/local/include/
++ PATHS /usr/include/
+ )
+
+ find_library(
+ assimp_LIBRARIES
+ NAMES assimp
+- PATHS /usr/local/lib/
++ PATHS /usr/lib/
+ )
+
+ if (assimp_INCLUDE_DIRS AND assimp_LIBRARIES)
+@@ -78,4 +78,4 @@
+ endif (assimp_FIND_REQUIRED)
+ endif (assimp_FOUND)
+
+-endif(WIN32)
+\ Brak znaku nowej linii na końcu pliku
++endif(WIN32)
diff --git a/media-libs/assimp/files/findassimp.patch b/media-libs/assimp/files/findassimp.patch
new file mode 100644
index 000000000000..1b62e7301ffe
--- /dev/null
+++ b/media-libs/assimp/files/findassimp.patch
@@ -0,0 +1,18 @@
+--- cmake-modules/Findassimp.cmake.old 2016-09-06 08:26:35.107697600 +0200
++++ cmake-modules/Findassimp.cmake 2016-09-06 08:29:25.337696582 +0200
+@@ -1,13 +1,13 @@
+ FIND_PATH(
+ assimp_INCLUDE_DIRS
+ NAMES postprocess.h scene.h version.h config.h cimport.h
+- PATHS /usr/local/include/
++ PATHS /usr/include/
+ )
+
+ FIND_LIBRARY(
+ assimp_LIBRARIES
+ NAMES assimp
+- PATHS /usr/local/lib/
++ PATHS /usr/lib/
+ )
+
+ IF (assimp_INCLUDE_DIRS AND assimp_LIBRARIES)
diff --git a/media-libs/assimp/files/test-cmakelists.patch b/media-libs/assimp/files/test-cmakelists.patch
new file mode 100644
index 000000000000..9a3471bbc36a
--- /dev/null
+++ b/media-libs/assimp/files/test-cmakelists.patch
@@ -0,0 +1,35 @@
+--- test/CMakeLists.txt.old 2016-01-21 06:46:12.053363212 +0100
++++ test/CMakeLists.txt 2016-01-21 06:46:51.126697143 +0100
+@@ -1,7 +1,5 @@
+ cmake_minimum_required( VERSION 2.6 )
+
+-INCLUDE( AddGTest )
+-
+ INCLUDE_DIRECTORIES(
+ ${Assimp_SOURCE_DIR}/include
+ ${Assimp_SOURCE_DIR}/code
+@@ -47,7 +45,7 @@
+
+ SOURCE_GROUP( tests FILES ${TEST_SRCS} )
+
+-if(AddGTest_FOUND)
++if(BUILD_TESTS)
+ add_executable( unit
+ unit/CCompilerTest.c
+ unit/Main.cpp
+@@ -56,13 +54,12 @@
+ )
+
+ add_definitions(-DASSIMP_TEST_MODELS_DIR="${CMAKE_CURRENT_LIST_DIR}/models")
++target_link_libraries( unit gtest )
+
+ SET_PROPERTY( TARGET assimp PROPERTY DEBUG_POSTFIX ${CMAKE_DEBUG_POSTFIX} )
+
+ add_dependencies( unit gtest )
+ target_link_libraries( unit assimp
+- debug ${GTEST_DEBUG_LIBRARIES}
+- optimized ${GTEST_RELEASE_LIBRARIES}
+ )
+-endif(AddGTest_FOUND)
++endif(BUILD_TESTS)
+ add_subdirectory(headercheck)