summaryrefslogtreecommitdiff
path: root/media-libs/assimp/files/assimp-5.2.5-gtest.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-20 14:08:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-20 14:08:57 +0000
commit6aa0d33a65c735f3148967b62316c2e71f43589a (patch)
tree4ddfb479a93b928f4ad0507a58e779e6de3eb403 /media-libs/assimp/files/assimp-5.2.5-gtest.patch
parenta332b8e207ac6a51fa349c699b486d870c9cdc70 (diff)
gentoo auto-resync : 20:01:2024 - 14:08:56
Diffstat (limited to 'media-libs/assimp/files/assimp-5.2.5-gtest.patch')
-rw-r--r--media-libs/assimp/files/assimp-5.2.5-gtest.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/assimp/files/assimp-5.2.5-gtest.patch b/media-libs/assimp/files/assimp-5.2.5-gtest.patch
new file mode 100644
index 000000000000..9441141337ac
--- /dev/null
+++ b/media-libs/assimp/files/assimp-5.2.5-gtest.patch
@@ -0,0 +1,30 @@
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index afe4874..5a87cc2 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -191,7 +191,6 @@ SET( POST_PROCESSES
+ unit/utRemoveComments.cpp
+ unit/utRemoveComponent.cpp
+ unit/utVertexTriangleAdjacency.cpp
+- unit/utJoinVertices.cpp
+ unit/utSplitLargeMeshes.cpp
+ unit/utFindDegenerates.cpp
+ unit/utFindInvalidData.cpp
+@@ -281,4 +281,6 @@ target_link_libraries( unit assimp ${platform_libs} )
+
+ add_subdirectory(headercheck)
+
+-add_test( unittests unit )
++get_target_property(unit_SOURCES unit SOURCES)
++find_package(GTest REQUIRED)
++gtest_add_tests(TARGET unit ${unit_SOURCES})
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -725,6 +725,7 @@ IF ( ASSIMP_BUILD_SAMPLES )
+ ENDIF ()
+
+ IF ( ASSIMP_BUILD_TESTS )
++ enable_testing()
+ ADD_SUBDIRECTORY( test/ )
+ ENDIF ()
+