summaryrefslogtreecommitdiff
path: root/media-libs/aribb24
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /media-libs/aribb24
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'media-libs/aribb24')
-rw-r--r--media-libs/aribb24/Manifest1
-rw-r--r--media-libs/aribb24/aribb24-1.0.3-r1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/aribb24/Manifest b/media-libs/aribb24/Manifest
index cbdedb468551..85806e6fab24 100644
--- a/media-libs/aribb24/Manifest
+++ b/media-libs/aribb24/Manifest
@@ -1,3 +1,4 @@
DIST aribb24-1.0.3.tar.gz 57378 BLAKE2B 72d5c56a214d63e477ed0bb77e5f20e79ff69fe3712623f54f1369b041622aef1853909f3dfc31685b346c62ef36ffe205bf7a8d2c9f0a2996ae378b025228b7 SHA512 622cc0c3928fd6db0b5ab3921f27348c956af20f8c0133ad5d9bf4de3d199077d9f23cc86ae149a9f0d13c7ee5906ec95de3fb8388207160cebd1f0c59078c8f
+EBUILD aribb24-1.0.3-r1.ebuild 692 BLAKE2B 31de88410fe23acfbfc52aca125563792566e296315b614ae07c0d378176d10722574eca4bb16d775ded48bb3bd2f679f92cb0f5bec2e6db952c77a9385218d5 SHA512 7650c1ccb3cdc429570da6a677b43c0721a41eafbae387908862123dc7f8f7f65283810cb9c91f0b037cf3b1db364b4da9836c37a7768657991b4584ebb91cd4
EBUILD aribb24-1.0.3.ebuild 610 BLAKE2B be387cc22c418985fe567238db2dfe1add1576f0484d3fc28162f4f47e4e6f22a2ecd642670d8f5dcb43d3866448b7cb6a0206032f9c25b525d9efcd9bd40054 SHA512 5fec871008d5d91cabb85d145327a748d910898b3eda002eb4efbdc7ab7eff4fa6cf0770b900986c8e8046a1e11a7338cdfc3ca55f0fef59eda79b1b9c1c2040
MISC metadata.xml 362 BLAKE2B a58d2df31cfb55e76bec5b2055ae17cbfed0de0a0cc85d8d604ee5c4442539b00d40500722b9a589861f6de1e49ef9fe171bdae2219325c93fc07b735a349949 SHA512 0266c8f4f74468aca028c09b9bd61817f1358022ba11020c5f1829581113c0510c4f59228304fe4a5e76f4a666c640e0afc6e96385bae7c0de98c5d4b8a64d44
diff --git a/media-libs/aribb24/aribb24-1.0.3-r1.ebuild b/media-libs/aribb24/aribb24-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..a6cba5266077
--- /dev/null
+++ b/media-libs/aribb24/aribb24-1.0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Library for decoding ARIB STD-B24 subtitles"
+HOMEPAGE="https://github.com/nkoriyama/aribb24"
+SRC_URI="https://github.com/nkoriyama/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+RDEPEND="media-libs/libpng:0=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf --disable-static
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -delete || die
+}