summaryrefslogtreecommitdiff
path: root/media-libs/amf-headers/amf-headers-1.4.30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-26 10:30:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-26 10:30:48 +0100
commit96cc0713998c294a9440f03dfa8c4adc9cb71f92 (patch)
treec51c399e2ac466345931e32f9bb465534a74f828 /media-libs/amf-headers/amf-headers-1.4.30.ebuild
parent390bde0d9e0b055c7e87ede2f6b3546ec7da02c7 (diff)
gentoo auto-resync : 26:07:2023 - 10:30:48
Diffstat (limited to 'media-libs/amf-headers/amf-headers-1.4.30.ebuild')
-rw-r--r--media-libs/amf-headers/amf-headers-1.4.30.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/amf-headers/amf-headers-1.4.30.ebuild b/media-libs/amf-headers/amf-headers-1.4.30.ebuild
new file mode 100644
index 000000000000..37174ce94183
--- /dev/null
+++ b/media-libs/amf-headers/amf-headers-1.4.30.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GPUOpen-LibrariesAndSDKs/AMF"
+else
+ SRC_URI="https://github.com/GPUOpen-LibrariesAndSDKs/AMF/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="The Advanced Media Framework (AMF) SDK"
+HOMEPAGE="https://github.com/GPUOpen-LibrariesAndSDKs/AMF"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/AMF-${PV}"
+
+src_unpack() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ insinto "/usr/include/AMF"
+ doins -r "${S}/amf/public/include/"*
+}