summaryrefslogtreecommitdiff
path: root/media-libs/amf-headers/amf-headers-1.4.26.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-17 20:33:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-17 20:33:10 +0100
commit1c9a2b6cf059fca455a527c1bd76a2321f93b310 (patch)
tree1b35cf6afe711f7eaedfe2e5fe41b14e517ee215 /media-libs/amf-headers/amf-headers-1.4.26.ebuild
parentb9d1ad143f4a37061059ce69b1251e23fd760f95 (diff)
gentoo auto-resync : 17:08:2022 - 20:33:10
Diffstat (limited to 'media-libs/amf-headers/amf-headers-1.4.26.ebuild')
-rw-r--r--media-libs/amf-headers/amf-headers-1.4.26.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/amf-headers/amf-headers-1.4.26.ebuild b/media-libs/amf-headers/amf-headers-1.4.26.ebuild
new file mode 100644
index 000000000000..f96ac72bc0e6
--- /dev/null
+++ b/media-libs/amf-headers/amf-headers-1.4.26.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GPUOpen-LibrariesAndSDKs/AMF"
+else
+ SRC_URI="https://github.com/GPUOpen-LibrariesAndSDKs/AMF/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="The Advanced Media Framework (AMF) SDK"
+HOMEPAGE="https://github.com/GPUOpen-LibrariesAndSDKs/AMF"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/AMF-${PV}"
+
+src_unpack() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ insinto "/usr/include/AMF"
+ doins -r "${S}/amf/public/include/"*
+}