summaryrefslogtreecommitdiff
path: root/media-libs/allegro/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/allegro/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/allegro/files')
-rw-r--r--media-libs/allegro/files/allegro-4.4.2-gentoo.patch16
-rw-r--r--media-libs/allegro/files/allegro-4.4.2-rpath.patch8
-rw-r--r--media-libs/allegro/files/allegro-4.4.2-shared.patch11
-rw-r--r--media-libs/allegro/files/allegro-4.4.2-underlink.patch11
-rw-r--r--media-libs/allegro/files/allegro-5.0.11-multilib.patch10
-rw-r--r--media-libs/allegro/files/allegro-5.0.11-underlink.patch11
6 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/allegro/files/allegro-4.4.2-gentoo.patch b/media-libs/allegro/files/allegro-4.4.2-gentoo.patch
new file mode 100644
index 000000000000..119d9c789508
--- /dev/null
+++ b/media-libs/allegro/files/allegro-4.4.2-gentoo.patch
@@ -0,0 +1,16 @@
+--- docs/CMakeLists.txt.old 2012-03-04 20:20:05.566881387 +0100
++++ docs/CMakeLists.txt 2012-03-04 20:20:50.659714153 +0100
+@@ -71,11 +71,12 @@
+ string(REGEX MATCH "[^/]*._tx" basename ${page})
+ string(REPLACE "._tx" "" basename ${basename})
+
+- set(page ${CMAKE_CURRENT_SOURCE_DIR}/${page})
+ if(${page} MATCHES "/build/")
++ set(page ${CMAKE_CURRENT_SOURCE_DIR}/${page})
+ set(txt_out ${CMAKE_CURRENT_BINARY_DIR}/build/${basename}.txt)
+ set(html_out ${CMAKE_CURRENT_BINARY_DIR}/build/${basename}.html)
+ else()
++ set(page ${CMAKE_CURRENT_SOURCE_DIR}/${page})
+ set(txt_out ${CMAKE_CURRENT_BINARY_DIR}/txt/${basename}.txt)
+ set(html_out ${CMAKE_CURRENT_BINARY_DIR}/html/${basename}.html)
+ endif()
diff --git a/media-libs/allegro/files/allegro-4.4.2-rpath.patch b/media-libs/allegro/files/allegro-4.4.2-rpath.patch
new file mode 100644
index 000000000000..57bdb6bf8d0e
--- /dev/null
+++ b/media-libs/allegro/files/allegro-4.4.2-rpath.patch
@@ -0,0 +1,8 @@
+--- setup/CMakeLists.txt
++++ setup/CMakeLists.txt
+@@ -1,3 +1,5 @@
++set(CMAKE_SKIP_BUILD_RPATH TRUE)
++
+ add_our_executable(setup setup.c)
+ copy_files(copy_setup_data setup.dat)
+
diff --git a/media-libs/allegro/files/allegro-4.4.2-shared.patch b/media-libs/allegro/files/allegro-4.4.2-shared.patch
new file mode 100644
index 000000000000..665c03e31204
--- /dev/null
+++ b/media-libs/allegro/files/allegro-4.4.2-shared.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -830,7 +830,7 @@
+ option(WANT_LOGG "Enable logg" on)
+ option(WANT_JPGALLEG "Enable JPGAlleg" on)
+
+-if(WANT_FRAMEWORKS)
++if(SHARED)
+ set(ADDON_LINKAGE SHARED)
+ else()
+ set(ADDON_LINKAGE STATIC)
diff --git a/media-libs/allegro/files/allegro-4.4.2-underlink.patch b/media-libs/allegro/files/allegro-4.4.2-underlink.patch
new file mode 100644
index 000000000000..33dc9d260b2d
--- /dev/null
+++ b/media-libs/allegro/files/allegro-4.4.2-underlink.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.old 2011-06-06 23:46:06.057320691 +0200
++++ CMakeLists.txt 2011-06-06 23:46:21.900313261 +0200
+@@ -392,7 +392,7 @@
+ message(FATAL_ERROR "Unix port requires pthreads support.")
+ endif()
+ set(ALLEGRO_HAVE_LIBPTHREAD 1)
+- list(APPEND PLATFORM_LIBS m ${CMAKE_THREAD_LIBS_INIT})
++ list(APPEND PLATFORM_LIBS dl m ${CMAKE_THREAD_LIBS_INIT})
+ list(APPEND PLATFORM_SOURCES ${ALLEGRO_SRC_UNIX_FILES})
+
+ if(WANT_OSS)
diff --git a/media-libs/allegro/files/allegro-5.0.11-multilib.patch b/media-libs/allegro/files/allegro-5.0.11-multilib.patch
new file mode 100644
index 000000000000..ffb0c25fc8b6
--- /dev/null
+++ b/media-libs/allegro/files/allegro-5.0.11-multilib.patch
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.old 2013-06-16 10:16:08.000000000 +0600
++++ CMakeLists.txt 2016-02-25 14:32:40.350446191 +0500
+@@ -560,7 +560,6 @@
+ endif(SUPPORT_X11 AND NOT SUPPORT_OPENGL)
+
+ if(SUPPORT_X11)
+- set(CMAKE_REQUIRED_LIBRARIES ${X11_LIBRARIES})
+
+ check_library_exists(Xcursor XcursorImageCreate "" CAN_XCURSOR)
+ if(CAN_XCURSOR)
diff --git a/media-libs/allegro/files/allegro-5.0.11-underlink.patch b/media-libs/allegro/files/allegro-5.0.11-underlink.patch
new file mode 100644
index 000000000000..7702c1d2c6db
--- /dev/null
+++ b/media-libs/allegro/files/allegro-5.0.11-underlink.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.old 2011-06-06 23:56:09.367125536 +0200
++++ CMakeLists.txt 2011-06-06 23:56:19.311748807 +0200
+@@ -703,7 +703,7 @@
+
+ if(ALLEGRO_UNIX) # not MACOSX
+ list(APPEND LIBRARY_SOURCES ${ALLEGRO_SRC_UNIX_FILES})
+- list(APPEND PLATFORM_LIBS m ${CMAKE_THREAD_LIBS_INIT})
++ list(APPEND PLATFORM_LIBS dl m ${CMAKE_THREAD_LIBS_INIT})
+ endif(ALLEGRO_UNIX)
+
+ if(SUPPORT_X11)