summaryrefslogtreecommitdiff
path: root/media-libs/aften/aften-0.0.8-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /media-libs/aften/aften-0.0.8-r2.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'media-libs/aften/aften-0.0.8-r2.ebuild')
-rw-r--r--media-libs/aften/aften-0.0.8-r2.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/media-libs/aften/aften-0.0.8-r2.ebuild b/media-libs/aften/aften-0.0.8-r2.ebuild
index f1dd9d2fa9ec..ab7fe29f0a45 100644
--- a/media-libs/aften/aften-0.0.8-r2.ebuild
+++ b/media-libs/aften/aften-0.0.8-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
-DESCRIPTION="An A/52 (AC-3) audio encoder"
+DESCRIPTION="A/52 (AC-3) audio encoder"
HOMEPAGE="http://aften.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -14,6 +14,8 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="cxx"
+DOCS=( README Changelog )
+
PATCHES=(
"${FILESDIR}/${P}-multilib.patch"
"${FILESDIR}/${P}-ppc.patch"
@@ -25,12 +27,11 @@ src_configure() {
-DSHARED=1
-DBINDINGS_CXX=$(usex cxx)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
- dodoc README Changelog
+ cmake_src_install
# File collision with media-sound/wavbreaker, upstream informed
mv "${ED}"/usr/bin/wavinfo{,-aften} || die
}