summaryrefslogtreecommitdiff
path: root/media-libs/aften/aften-0.0.8-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/aften/aften-0.0.8-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/aften/aften-0.0.8-r2.ebuild')
-rw-r--r--media-libs/aften/aften-0.0.8-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/aften/aften-0.0.8-r2.ebuild b/media-libs/aften/aften-0.0.8-r2.ebuild
new file mode 100644
index 000000000000..65594d77cbbd
--- /dev/null
+++ b/media-libs/aften/aften-0.0.8-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An A/52 (AC-3) audio encoder"
+HOMEPAGE="http://aften.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cxx"
+
+PATCHES=(
+ "${FILESDIR}/${P}-multilib.patch"
+ "${FILESDIR}/${P}-ppc.patch"
+ "${FILESDIR}/${P}-no-static-aften.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DSHARED=1
+ -DBINDINGS_CXX=$(usex cxx)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README Changelog
+ # File collision with media-sound/wavbreaker, upstream informed
+ mv "${D}"/usr/bin/wavinfo{,-aften} || die
+}