summaryrefslogtreecommitdiff
path: root/media-gfx/xdot/xdot-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-18 00:01:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-18 00:01:42 +0100
commit075fd1f8cabc5879c6eb42127fb84c3058677fde (patch)
tree8b761e85416656264e041b1954427a58894b3333 /media-gfx/xdot/xdot-1.4.ebuild
parent6c9dc10e04cd513437e046ccca0e51a3d6d4dc7c (diff)
gentoo auto-resync : 18:05:2024 - 00:01:41
Diffstat (limited to 'media-gfx/xdot/xdot-1.4.ebuild')
-rw-r--r--media-gfx/xdot/xdot-1.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/xdot/xdot-1.4.ebuild b/media-gfx/xdot/xdot-1.4.ebuild
new file mode 100644
index 000000000000..bfd164986323
--- /dev/null
+++ b/media-gfx/xdot/xdot-1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+MY_PN=xdot.py
+EGIT_REPO_URI="https://github.com/jrfonseca/${MY_PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ MY_P="${MY_PN}-${PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/jrfonseca/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+inherit ${GIT_ECLASS} distutils-r1 virtualx
+
+DESCRIPTION="Interactive viewer for Graphviz dot files"
+HOMEPAGE="https://github.com/jrfonseca/xdot.py"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ test? ( x11-libs/gtk+:3[X] )
+"
+RDEPEND="${DEPEND}"
+
+run_test() {
+ cd tests && "${EPYTHON}" ../test.py *.dot graphs/*.gv
+ return "${?}"
+}
+
+python_test() {
+ virtx run_test
+}