summaryrefslogtreecommitdiff
path: root/media-gfx/xdot/xdot-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 10:35:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 10:35:29 +0100
commit5067796b074450a155155c782ef4885c885cfb2b (patch)
tree68109e52982e612f48c05614ff09888cb33668ac /media-gfx/xdot/xdot-1.3.ebuild
parent68d015b395b17126b8651edb61c80fca8c5968c1 (diff)
gentoo auto-resync : 10:09:2023 - 10:35:29
Diffstat (limited to 'media-gfx/xdot/xdot-1.3.ebuild')
-rw-r--r--media-gfx/xdot/xdot-1.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/xdot/xdot-1.3.ebuild b/media-gfx/xdot/xdot-1.3.ebuild
new file mode 100644
index 000000000000..dc0e15d5f30b
--- /dev/null
+++ b/media-gfx/xdot/xdot-1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+MY_PN=xdot.py
+EGIT_REPO_URI="https://github.com/jrfonseca/${MY_PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ MY_P="${MY_PN}-${PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/jrfonseca/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+inherit ${GIT_ECLASS} distutils-r1 virtualx
+
+DESCRIPTION="Interactive viewer for Graphviz dot files"
+HOMEPAGE="https://github.com/jrfonseca/xdot.py"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ test? ( x11-libs/gtk+:3[X] )
+"
+RDEPEND="${DEPEND}"
+
+run_test() {
+ cd tests && "${EPYTHON}" ../test.py *.dot graphs/*.gv
+ return "${?}"
+}
+
+python_test() {
+ virtx run_test
+}