summaryrefslogtreecommitdiff
path: root/media-gfx/word_cloud/word_cloud-1.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /media-gfx/word_cloud/word_cloud-1.8.1.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'media-gfx/word_cloud/word_cloud-1.8.1.ebuild')
-rw-r--r--media-gfx/word_cloud/word_cloud-1.8.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/word_cloud/word_cloud-1.8.1.ebuild b/media-gfx/word_cloud/word_cloud-1.8.1.ebuild
new file mode 100644
index 000000000000..566b07c3986f
--- /dev/null
+++ b/media-gfx/word_cloud/word_cloud-1.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A little word cloud generator in Python"
+HOMEPAGE="https://amueller.github.io/word_cloud/"
+SRC_URI="https://github.com/amueller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-fonts/droid"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.0-bundled-font.patch )