summaryrefslogtreecommitdiff
path: root/media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-20 01:00:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-20 01:00:14 +0000
commitf4106f0cb3d17dc4c85cd4d45816e2c18a8d29e2 (patch)
tree30f32cdcaa065cf7695f6f848d3fa7bfa998619a /media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild
parent8cb1b7629fb6936b7008bd364b5e4ec3ecf6f6cd (diff)
gentoo auto-resync : 20:03:2024 - 01:00:13
Diffstat (limited to 'media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild')
-rw-r--r--media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild b/media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild
new file mode 100644
index 000000000000..0474ba4b3c29
--- /dev/null
+++ b/media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="A Vulkan post-processing layer for Linux"
+HOMEPAGE="https://github.com/DadSchoorse/vkBasalt"
+SRC_URI="https://github.com/DadSchoorse/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers"
+BDEPEND="dev-util/glslang
+ virtual/pkgconfig"