summaryrefslogtreecommitdiff
path: root/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
commit5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (patch)
treeb041acef19bb9ae66c228d5c9d34d1e00aeb2b95 /media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
parent5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (diff)
gentoo resync : 22.04.2018
Diffstat (limited to 'media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild')
-rw-r--r--media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
index 22552436a69b..2a5d72d35690 100644
--- a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
+++ b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils
+inherit distutils-r1 xdg-utils
DESCRIPTION="Convert vector graphic file formats like .cdr, .svg, wmf and more."
HOMEPAGE="https://sk1project.net/modules.php?name=Products&product=uniconvertor"
@@ -61,3 +61,13 @@ python_test() {
cd src/unittests || die
${EPYTHON} all_tests.py || die
}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}