summaryrefslogtreecommitdiff
path: root/media-gfx/ufraw/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/ufraw/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/ufraw/files')
-rw-r--r--media-gfx/ufraw/files/ufraw-0.17-cfitsio-automagic.patch28
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-crashfix.patch15
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-drop_superfluous_abs.patch16
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch20
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-jasper-automagic.patch21
5 files changed, 100 insertions, 0 deletions
diff --git a/media-gfx/ufraw/files/ufraw-0.17-cfitsio-automagic.patch b/media-gfx/ufraw/files/ufraw-0.17-cfitsio-automagic.patch
new file mode 100644
index 000000000000..aff7c5a25930
--- /dev/null
+++ b/media-gfx/ufraw/files/ufraw-0.17-cfitsio-automagic.patch
@@ -0,0 +1,28 @@
+diff -ru ufraw-0.17.orig/configure.ac ufraw-0.17/configure.ac
+--- ufraw-0.17.orig/configure.ac 2010-04-02 16:16:08.000000000 +0200
++++ ufraw-0.17/configure.ac 2010-04-02 16:19:33.000000000 +0200
+@@ -246,11 +246,19 @@
+ [ have_png=no
+ AC_MSG_RESULT($LIBPNG_PKG_ERRORS) ] )
+
+-PKG_CHECK_MODULES(CFITSIO, cfitsio,
+- [ have_cfitsio=yes
+- AC_DEFINE(HAVE_LIBCFITSIO, 1, have the cfitsio library) ],
+- [ have_cfitsio=no
+- AC_MSG_RESULT($CFITSIO_PKG_ERRORS) ] )
++AC_ARG_WITH([cfitsio],
++ [AS_HELP_STRING([--with-cfitsio],
++ [build fits support @<:@default=check@:>@])],
++ [],
++ [with_cfitsio=check])
++
++have_cfitsio=no
++AS_IF([test "x$with_cfitsio" != xno],
++ [PKG_CHECK_MODULES(CFITSIO, cfitsio,
++ [ have_cfitsio=yes
++ AC_DEFINE(HAVE_LIBCFITSIO, 1, have the cfitsio library) ],
++ [ have_cfitsio=no
++ AC_MSG_RESULT($CFITSIO_PKG_ERRORS) ] ) ] )
+
+ PKG_CHECK_MODULES(EXIV2, exiv2 >= 0.16,
+ [ have_exiv2=yes
diff --git a/media-gfx/ufraw/files/ufraw-0.22-crashfix.patch b/media-gfx/ufraw/files/ufraw-0.22-crashfix.patch
new file mode 100644
index 000000000000..76fe83fa8f2e
--- /dev/null
+++ b/media-gfx/ufraw/files/ufraw-0.22-crashfix.patch
@@ -0,0 +1,15 @@
+--- a/ufraw_ufraw.c 2015-06-16 04:58:38.000000000 +0100
++++ b/ufraw_ufraw.c 2016-12-18 00:55:45.794466747 +0000
+@@ -767,8 +767,10 @@ void ufraw_close(ufraw_data *uf)
+ g_free(uf->displayProfile);
+ g_free(uf->RawHistogram);
+ #ifdef HAVE_LENSFUN
+- lf_modifier_destroy(uf->TCAmodifier);
+- lf_modifier_destroy(uf->modifier);
++ if (uf->TCAmodifier != NULL)
++ lf_modifier_destroy(uf->TCAmodifier);
++ if (uf->modifier != NULL)
++ lf_modifier_destroy(uf->modifier);
+ #endif
+ ufobject_delete(uf->conf->ufobject);
+ g_free(uf->conf);
diff --git a/media-gfx/ufraw/files/ufraw-0.22-drop_superfluous_abs.patch b/media-gfx/ufraw/files/ufraw-0.22-drop_superfluous_abs.patch
new file mode 100644
index 000000000000..8c11f6649781
--- /dev/null
+++ b/media-gfx/ufraw/files/ufraw-0.22-drop_superfluous_abs.patch
@@ -0,0 +1,16 @@
+Fixes build with gcc 7, by Johannes Hirte.
+https://bugs.gentoo.org/show_bug.cgi?id=618068
+
+diff --git a/../old/dcraw.cc b/dcraw.cc
+index 88c8068..cedf86b 100644
+--- a/../old/dcraw.cc
++++ b/dcraw.cc
+@@ -9242,7 +9242,7 @@ canon_a5:
+ if (make[0] == 'O') {
+ i = find_green (12, 32, 1188864, 3576832);
+ c = find_green (12, 32, 2383920, 2387016);
+- if (abs(i) < abs(c)) {
++ if (i < c) {
+ SWAP(i,c);
+ load_flags = 24;
+ }
diff --git a/media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch b/media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch
new file mode 100644
index 000000000000..a5397260ffb5
--- /dev/null
+++ b/media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch
@@ -0,0 +1,20 @@
+Description: Fix unsigned char declaration of src[]
+Author: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
+Last-Update: 2017-02-27
+
+https://bugs.gentoo.org/show_bug.cgi?id=622484
+https://sourceforge.net/p/ufraw/bugs/417/
+https://src.fedoraproject.org/cgit/rpms/ufraw.git/tree/05_fix_build_due_to_unsigned_char.patch
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=856227
+
+--- ufraw-0.22.orig/dcraw.cc
++++ ufraw-0.22/dcraw.cc
+@@ -2285,7 +2285,7 @@ void CLASS quicktake_100_load_raw()
+
+ void CLASS kodak_radc_load_raw()
+ {
+- static const char src[] = {
++ static const signed char src[] = {
+ 1,1, 2,3, 3,4, 4,2, 5,7, 6,5, 7,6, 7,8,
+ 1,0, 2,1, 3,3, 4,4, 5,2, 6,7, 7,6, 8,5, 8,8,
+ 2,1, 2,3, 3,0, 3,2, 3,4, 4,6, 5,5, 6,7, 6,8,
diff --git a/media-gfx/ufraw/files/ufraw-0.22-jasper-automagic.patch b/media-gfx/ufraw/files/ufraw-0.22-jasper-automagic.patch
new file mode 100644
index 000000000000..93e1d691af1d
--- /dev/null
+++ b/media-gfx/ufraw/files/ufraw-0.22-jasper-automagic.patch
@@ -0,0 +1,21 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -159,8 +159,16 @@
+ have_jpeg=${ac_cv_lib_jpeg_jpeg_CreateCompress:-no}
+
+ # Check for libjasper.
+-AC_CHECK_LIB(jasper, jas_image_decode)
+-have_jasper=${ac_cv_lib_jasper_jas_image_decode:-no}
++AC_ARG_ENABLE([jasper],
++ AS_HELP_STRING([--enable-jasper], [enable JPEG2000 support]))
++
++have_jasper=no
++AS_IF([test "x$enable_jasper" = "xyes"], [
++ AC_SEARCH_LIBS([jas_image_decode], [jasper], [have_jasper=yes], [
++ AC_MSG_ERROR([unable to find the jas_image_decode() function])
++ ])
++])
++
+
+ # Check for tiff headers and library.
+ PKG_CHECK_MODULES(LIBTIFF, libtiff-4,