summaryrefslogtreecommitdiff
path: root/media-gfx/ueberzugpp/ueberzugpp-2.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-22 02:55:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-22 02:55:39 +0100
commit470949042cc90856adb62f2671e04e3165fc8063 (patch)
treee577a02af2278fdc686930a13421f68abe332fd6 /media-gfx/ueberzugpp/ueberzugpp-2.8.2.ebuild
parenteb509e1a15f595f667e8d177ddb73311084af6c0 (diff)
gentoo auto-resync : 22:05:2023 - 02:55:39
Diffstat (limited to 'media-gfx/ueberzugpp/ueberzugpp-2.8.2.ebuild')
-rw-r--r--media-gfx/ueberzugpp/ueberzugpp-2.8.2.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/media-gfx/ueberzugpp/ueberzugpp-2.8.2.ebuild b/media-gfx/ueberzugpp/ueberzugpp-2.8.2.ebuild
deleted file mode 100644
index 29694cec2261..000000000000
--- a/media-gfx/ueberzugpp/ueberzugpp-2.8.2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Drop in replacement for ueberzug written in C++"
-HOMEPAGE="https://github.com/jstkdng/ueberzugpp/"
-SRC_URI="https://github.com/jstkdng/ueberzugpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="X opencv"
-
-RDEPEND="
- dev-cpp/tbb:=
- dev-libs/glib:2
- dev-libs/libfmt:=
- dev-libs/openssl:=
- dev-libs/spdlog:=
- media-libs/libsixel
- media-libs/vips:=
- net-libs/zeromq:=
- X? (
- x11-libs/libxcb:=
- x11-libs/xcb-util-image
- )
- opencv? ( media-libs/opencv:= )
- !media-gfx/ueberzug"
-DEPEND="
- ${RDEPEND}
- dev-cpp/cli11
- dev-cpp/ms-gsl
- dev-cpp/nlohmann_json
- net-libs/cppzmq
- X? ( x11-base/xorg-proto )"
-
-src_configure() {
- CMAKE_BUILD_TYPE=Release # install target wants this
-
- local mycmakeargs=(
- -DENABLE_OPENCV=$(usex opencv)
- -DENABLE_X11=$(usex X)
- -DENABLE_TURBOBASE64=no # not packaged
- -DFETCHCONTENT_FULLY_DISCONNECTED=yes
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # not handled by cmake, but upstream creates the pp symlink in their
- # self-maintained AUR package and some scripts like ytfzf look for it
- dosym ueberzug /usr/bin/${PN}
-}