summaryrefslogtreecommitdiff
path: root/media-gfx/ttygif/files/ldflags-support.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /media-gfx/ttygif/files/ldflags-support.patch
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'media-gfx/ttygif/files/ldflags-support.patch')
-rw-r--r--media-gfx/ttygif/files/ldflags-support.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/media-gfx/ttygif/files/ldflags-support.patch b/media-gfx/ttygif/files/ldflags-support.patch
new file mode 100644
index 000000000000..201f72fb04a6
--- /dev/null
+++ b/media-gfx/ttygif/files/ldflags-support.patch
@@ -0,0 +1,19 @@
+--- a/Makefile 2020-06-09 12:07:21.881455454 -0000
++++ b/Makefile 2020-06-09 12:08:43.984010587 -0000
+@@ -2,6 +2,7 @@
+ VERSION = '"1.4.0"'
+ CFLAGS += -O2 -Wall -DVERSION=$(VERSION)
+ PREFIX ?= /usr/local
++LDFLAGS ?= -L/usr/lib
+
+ UNAME := $(shell uname)
+ ifeq ($(UNAME), Darwin)
+@@ -14,7 +15,7 @@
+ all: ttygif
+
+ ttygif: ttygif.o io.o string_builder.o utils.o
+- $(CC) $(CFLAGS) -o ttygif ttygif.o io.o string_builder.o utils.o
++ $(CC) $(CFLAGS) -o ttygif ttygif.o io.o string_builder.o utils.o $(LDFLAGS)
+
+ install: ttygif
+ install -d $(PREFIX)/bin