summaryrefslogtreecommitdiff
path: root/media-gfx/sxiv/sxiv-26.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /media-gfx/sxiv/sxiv-26.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'media-gfx/sxiv/sxiv-26.ebuild')
-rw-r--r--media-gfx/sxiv/sxiv-26.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-gfx/sxiv/sxiv-26.ebuild b/media-gfx/sxiv/sxiv-26.ebuild
new file mode 100644
index 000000000000..ff78c92751b8
--- /dev/null
+++ b/media-gfx/sxiv/sxiv-26.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils savedconfig toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/muennich/sxiv.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/muennich/sxiv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Simple (or small or suckless) X Image Viewer"
+HOMEPAGE="https://github.com/muennich/sxiv/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="exif gif +jpeg +png"
+
+RDEPEND="
+ exif? ( media-libs/libexif )
+ gif? ( media-libs/giflib:0= )
+ media-libs/imlib2[X,gif?,jpeg?,png?]
+ x11-libs/libX11
+ x11-libs/libXft
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ restore_config config.h
+ default
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" HAVE_LIBEXIF=$(usex exif 1 0) HAVE_GIFLIB=$(usex gif 1 0)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX=/usr install
+ emake -C icon DESTDIR="${ED}" PREFIX=/usr install
+ dodoc README.md
+ domenu sxiv.desktop
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}