summaryrefslogtreecommitdiff
path: root/media-gfx/svg2rlg/svg2rlg-0.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-27 19:17:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-27 19:17:39 +0000
commit3dcb63f53c77ffe3c5b1ff3776c8254c593d1d55 (patch)
treebeb2f48ee9d6632607931765f11741706a3d4827 /media-gfx/svg2rlg/svg2rlg-0.4.0-r1.ebuild
parentb44896ea03d59328305f2dc8fb8987b21983cfb2 (diff)
gentoo auto-resync : 27:11:2022 - 19:17:39
Diffstat (limited to 'media-gfx/svg2rlg/svg2rlg-0.4.0-r1.ebuild')
-rw-r--r--media-gfx/svg2rlg/svg2rlg-0.4.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/svg2rlg/svg2rlg-0.4.0-r1.ebuild b/media-gfx/svg2rlg/svg2rlg-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..696d7e71f64a
--- /dev/null
+++ b/media-gfx/svg2rlg/svg2rlg-0.4.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts SVG files to PDFs or reportlab graphics"
+HOMEPAGE="
+ https://github.com/sarnold/svg2rlg/
+ https://pypi.org/project/svg2rlg/
+"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/svg2rlg.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sarnold/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-python/reportlab[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test_svg2rlg.py
+}