summaryrefslogtreecommitdiff
path: root/media-gfx/svg2rlg/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/svg2rlg/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/svg2rlg/files')
-rw-r--r--media-gfx/svg2rlg/files/svg2rlg-issue-3.patch19
-rw-r--r--media-gfx/svg2rlg/files/svg2rlg-issue-6.patch47
-rw-r--r--media-gfx/svg2rlg/files/svg2rlg-issue-7.patch16
3 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/svg2rlg/files/svg2rlg-issue-3.patch b/media-gfx/svg2rlg/files/svg2rlg-issue-3.patch
new file mode 100644
index 000000000000..df70bf345aa8
--- /dev/null
+++ b/media-gfx/svg2rlg/files/svg2rlg-issue-3.patch
@@ -0,0 +1,19 @@
+commit e5aa6784a10717641bc5b6d9d77a5029f815654a
+Author: yac <yac@blesmrt.net>
+Date: Wed May 8 04:59:17 2013 +0200
+
+ fix #3
+
+ remove windows only function which is useless anyway
+
+diff --git a/svg2rlg.py b/svg2rlg.py
+index 1c5f80c..2b35c62 100644
+--- a/svg2rlg.py
++++ b/svg2rlg.py
+@@ -1574,5 +1574,3 @@ if __name__ == "__main__":
+
+ drawing = svg2rlg(source)
+ drawing.save(formats=['pdf'],outDir='.',fnRoot=name)
+-
+- os.startfile(name + '.pdf')
+\ No newline at end of file
diff --git a/media-gfx/svg2rlg/files/svg2rlg-issue-6.patch b/media-gfx/svg2rlg/files/svg2rlg-issue-6.patch
new file mode 100644
index 000000000000..6ca750e79193
--- /dev/null
+++ b/media-gfx/svg2rlg/files/svg2rlg-issue-6.patch
@@ -0,0 +1,47 @@
+commit e42661b9cd6d7b71ce5e7674ac8eff25c74db07a
+Author: yac <yac@blesmrt.net>
+Date: Wed May 8 05:00:32 2013 +0200
+
+ use entry_point fixes #6
+
+diff --git a/setup.py b/setup.py
+index 9e00fba..512fa79 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,6 +1,6 @@
+ #!/usr/bin/python
+ # -*- coding: utf-8 -*-
+-from distutils.core import setup
++from setuptools import setup
+
+ setup(
+ name = 'svg2rlg',
+@@ -12,6 +12,8 @@ setup(
+ url = 'http://code.google.com/p/svg2rlg/',
+ download_url = 'http://pypi.python.org/pypi/svg2rlg/',
+ requires = ['reportlab'],
++ entry_points = {
++ 'console_scripts': ['svg2rlg = svg2rlg:main']},
+
+ classifiers=[
+ 'Environment :: Console',
+@@ -30,4 +32,4 @@ The authors motivation was to have a more robust handling of
+ SVG files in the **rst2pdf** tool. Specific to be able to handle
+ the quirks needed to include SVG export from matplotlib.
+ '''
+-)
+\ No newline at end of file
++)
+diff --git a/svg2rlg.py b/svg2rlg.py
+index 2b35c62..cc812b2 100644
+--- a/svg2rlg.py
++++ b/svg2rlg.py
+@@ -1562,7 +1562,7 @@ def svg2rlg(filename):
+
+ return renderer.render(xml)
+
+-if __name__ == "__main__":
++def main():
+ import sys
+ import os
+
diff --git a/media-gfx/svg2rlg/files/svg2rlg-issue-7.patch b/media-gfx/svg2rlg/files/svg2rlg-issue-7.patch
new file mode 100644
index 000000000000..8145f416f804
--- /dev/null
+++ b/media-gfx/svg2rlg/files/svg2rlg-issue-7.patch
@@ -0,0 +1,16 @@
+commit c30b4f90cac69934761e44bf59a8ba8a3827d647
+Author: yac <yac@blesmrt.net>
+Date: Wed May 8 05:44:00 2013 +0200
+
+ fix #7
+
+diff --git a/svg2rlg.py b/svg2rlg.py
+index cc812b2..80d72de 100644
+--- a/svg2rlg.py
++++ b/svg2rlg.py
+@@ -1573,4 +1573,4 @@ def main():
+ name, ext = os.path.splitext(filename)
+
+ drawing = svg2rlg(source)
+- drawing.save(formats=['pdf'],outDir='.',fnRoot=name)
++ drawing.save(formats=['pdf'],outDir=os.getcwd(),fnRoot=name)