summaryrefslogtreecommitdiff
path: root/media-gfx/springgraph/springgraph-88.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /media-gfx/springgraph/springgraph-88.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'media-gfx/springgraph/springgraph-88.ebuild')
-rw-r--r--media-gfx/springgraph/springgraph-88.ebuild32
1 files changed, 14 insertions, 18 deletions
diff --git a/media-gfx/springgraph/springgraph-88.ebuild b/media-gfx/springgraph/springgraph-88.ebuild
index 31742ab52d12..eb82210357fa 100644
--- a/media-gfx/springgraph/springgraph-88.ebuild
+++ b/media-gfx/springgraph/springgraph-88.ebuild
@@ -1,39 +1,35 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils
-
-DESCRIPTION="Generate spring graphs from graphviz input files"
-HOMEPAGE="http://www.chaosreigns.com/code/springgraph"
MY_PV="0.${PV}"
MY_P="${PN}_${MY_PV}"
SRC_FILE="${MY_P}.orig.tar.gz"
SRC_DEBIAN_PATCH="${PN}_0.82-5.diff.gz"
+
+DESCRIPTION="Generate spring graphs from graphviz input files"
+HOMEPAGE="http://www.chaosreigns.com/code/springgraph"
SRC_URI="http://www.chaosreigns.com/code/springgraph/dl/${PN}.pl.${PV}
- mirror://debian/pool/main/${PN:0:1}/${PN}/${SRC_DEBIAN_PATCH}"
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${SRC_DEBIAN_PATCH}"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-DEPEND=""
+
RDEPEND="dev-perl/GD"
-S="${WORKDIR}/${PN}-${MY_PV}"
-src_unpack() {
- mkdir -p ${S}
- cp ${DISTDIR}/${PN}.pl.${PV} ${S}/${PN}
- EPATCH_OPTS="-p1 -d ${S}" epatch ${DISTDIR}/${SRC_DEBIAN_PATCH}
-}
+S=${WORKDIR}
+
+PATCHES=( "${SRC_DEBIAN_PATCH%.gz}" )
-src_compile() {
- # nothing to do
- :
+src_unpack() {
+ cp "${DISTDIR}"/${PN}.pl.${PV} ${PN} || die
+ default
}
src_install() {
- into /usr
dobin ${PN}
doman debian/${PN}.1
}