summaryrefslogtreecommitdiff
path: root/media-gfx/shotwell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
commitb6fa31c964a602f8461a77d5b83355e8750c12eb (patch)
tree323fa7af31640b3ea8bb57fa7a927713f3d64769 /media-gfx/shotwell
parent868fd5dc8aab84930cfaa5252b8be06b35552765 (diff)
gentoo auto-resync : 16:07:2024 - 12:27:58
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/Manifest2
-rw-r--r--media-gfx/shotwell/shotwell-0.32.7.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 71ba9c18b91b..34c7499ad4c4 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,3 +1,5 @@
DIST shotwell-0.32.4.tar.xz 35335296 BLAKE2B 32be135643f165f32f315c332a4f0b34cd724285e7239eadbb250253b27ce97fb15d314f68a5392d88224a0b97f7f6ef8789c1f6c40051c26a25b9012e860b90 SHA512 516ab26d6620429175097886a1874d2eaf0513f6ef732bef5ee07ef8cd200028b34d98f4eb09b47a621f5313de42a5f415185d76853de478e0b5e0c4e89eea69
+DIST shotwell-0.32.7.tar.xz 35339216 BLAKE2B db87ee9c161f57dad638b47c37fb2737c95645e987e2bab81697895d9a28f14ab22b4669f218ea0baadfc0e1115f45fb9b094f546299083d83d2486fa1c15f98 SHA512 3cb9c9f2981ead8410f42680f6b4976d3b2efcfe7ded4d5217d28ebb8e5c968062a004ad3353affa13e94d996208ebf26c01f4beaf03a2ef6a1bc43960488d14
EBUILD shotwell-0.32.4.ebuild 2199 BLAKE2B 50ac5f6cd764cb515945ceb700230845bb200be64a7e7bb94f88847ae351238b1b0352b64b0886e92140471636987add46d3aeb81363ff541a0502884b7a2547 SHA512 86cff4865ca7f7305b58799049e085ea7a03ff93f0738fe33c98680d863c15e48df2425e550717905908659ec6a8e9d604d97c51bc58414def714dd9726a3fc2
+EBUILD shotwell-0.32.7.ebuild 2205 BLAKE2B b8fccde94ab5fc0b40d3cecf6bb889a505ce2f485864fbc9201a7242270369401b83f51228e9c91fe6750346813d2d16aaab1654a7c07705abae86580cc08c8e SHA512 ba4842cc36e539c84bfcd76c79dd7291cc573318fa579c83c797f55d43c28e954caa0be5840208fbf0dd3235d754a8001393f1f3dcf2434668163ee6b2742790
MISC metadata.xml 794 BLAKE2B c1eb4a08828db11ba473fe21036201d3b57c2fa36a2bd39b18e7671cf5e4c42b2b9e82956456a0376a60bfc982d9af106577075d936dba3c0cb73947da46f427 SHA512 2c65cdf3c6d5a953b52ad81e0a85d1c1465f5c38c3475e5c1408baea0b14a053255e97c0efc560059c77c51dbe98b72a90c6164fe575e68cba3eb04d4774f490
diff --git a/media-gfx/shotwell/shotwell-0.32.7.ebuild b/media-gfx/shotwell/shotwell-0.32.7.ebuild
new file mode 100644
index 000000000000..3f297331f776
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.32.7.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson optfeature vala xdg
+
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86"
+IUSE="opencv udev"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8.5:0.8=
+ >=net-libs/webkit-gtk-2.26:4.1
+ net-libs/libsoup:3.0
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libxml2-2.6.32:2
+ x11-libs/gdk-pixbuf:2
+ >=dev-db/sqlite-3.5.9:3
+ >=media-libs/gstreamer-1.20:1.0
+ >=media-libs/gst-plugins-base-1.20:1.0
+ >=media-libs/libgphoto2-2.5:=
+ udev? ( >=dev-libs/libgudev-145:= )
+ >=media-libs/gexiv2-0.12.3
+ >=media-libs/libraw-0.13.2:=
+ >=media-libs/libexif-0.6.16
+ app-crypt/libsecret
+ >=dev-libs/libportal-0.5:=[gtk]
+ media-libs/libwebp:=
+
+ >=app-crypt/gcr-3:0=[gtk]
+ x11-libs/cairo
+ opencv? ( >=media-libs/opencv-4.0.0:= )
+"
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ net-libs/libsoup:3.0[vala]
+ media-libs/gexiv2[vala]
+ app-crypt/gcr:0[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dunity_support=false
+ # -Dpublishers # In 0.30.2 all get compiled in anyways, even if restricted list, affects only runtime support
+ #trace
+ #measure
+ -Ddupe_detection=true
+ $(meson_use udev)
+ -Dinstall_apport_hook=false
+ $(meson_use opencv face_detection)
+ -Dfatal_warnings=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ optfeature "Enable support for the AVIF format" media-libs/libavif[gdk-pixbuf]
+ optfeature "Enable support for the HEIF format" media-libs/libheif[gdk-pixbuf]
+ optfeature "Enable support for the JPEG format" x11-libs/gdk-pixbuf[jpeg]
+ optfeature "Enable support for the TIFF format" x11-libs/gdk-pixbuf[tiff]
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}