summaryrefslogtreecommitdiff
path: root/media-gfx/sfftobmp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/sfftobmp/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/sfftobmp/files')
-rw-r--r--media-gfx/sfftobmp/files/sfftobmp-3.1.1-gcc44-and-boost-1_37.patch33
-rw-r--r--media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost_fs3.patch21
2 files changed, 54 insertions, 0 deletions
diff --git a/media-gfx/sfftobmp/files/sfftobmp-3.1.1-gcc44-and-boost-1_37.patch b/media-gfx/sfftobmp/files/sfftobmp-3.1.1-gcc44-and-boost-1_37.patch
new file mode 100644
index 000000000000..3ba832afaed6
--- /dev/null
+++ b/media-gfx/sfftobmp/files/sfftobmp-3.1.1-gcc44-and-boost-1_37.patch
@@ -0,0 +1,33 @@
+Only in sfftobmp3_1_1: Makefile.am.orig
+Only in sfftobmp3_1_1: Makefile.am.rej
+diff -ur sfftobmp3_1_1.orig/src/cmdline.cpp sfftobmp3_1_1/src/cmdline.cpp
+--- sfftobmp3_1_1.orig/src/cmdline.cpp 2007-10-07 22:01:21.000000000 +0300
++++ sfftobmp3_1_1/src/cmdline.cpp 2009-05-09 00:33:06.000000000 +0300
+@@ -35,6 +35,7 @@
+
+ ---RCS-Info--------------------------------------------------*/
+
++#include <cstdio>
+ #include <vector>
+ #include <cassert>
+ #include <iostream>
+diff -ur sfftobmp3_1_1.orig/src/common.cpp sfftobmp3_1_1/src/common.cpp
+--- sfftobmp3_1_1.orig/src/common.cpp 2007-10-07 22:01:20.000000000 +0300
++++ sfftobmp3_1_1/src/common.cpp 2009-05-09 00:28:37.000000000 +0300
+@@ -49,6 +49,7 @@
+ #include <sys/utime.h>
+ #endif
+
++#include <cstdio>
+ #include <cassert>
+ #include <iostream>
+
+diff -ur sfftobmp3_1_1.orig/src/Makefile.am sfftobmp3_1_1/src/Makefile.am
+--- sfftobmp3_1_1.orig/src/Makefile.am 2006-10-24 23:14:19.000000000 +0300
++++ sfftobmp3_1_1/src/Makefile.am 2009-05-09 00:27:42.000000000 +0300
+@@ -3,4 +3,4 @@
+ INCLUDES = -I$(top_builddir) -I$(top_srcdir)
+ bin_PROGRAMS = sfftobmp
+ sfftobmp_SOURCES = my_getopt.c cmdline.cpp codes.cpp common.cpp decoder.cpp input.cpp main.cpp output.cpp
+-sfftobmp_LDADD = @TIFF_LIB@ @JPEG_LIB@ -lboost_filesystem
++sfftobmp_LDADD = @TIFF_LIB@ @JPEG_LIB@ -lboost_filesystem -lboost_system
diff --git a/media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost_fs3.patch b/media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost_fs3.patch
new file mode 100644
index 000000000000..f39d157e1972
--- /dev/null
+++ b/media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost_fs3.patch
@@ -0,0 +1,21 @@
+http://bugs.gentoo.org/425364
+
+--- src/cmdline.cpp
++++ src/cmdline.cpp
+@@ -264,14 +264,14 @@
+ }
+ do {
+ if (!(fd.dwFileAttributes & FILE_ATTRIBUTE_DIRECTORY)) {
+- m_vFiles.push_back( fs::path(fd.cFileName, fs::native) );
++ m_vFiles.push_back( fs::path(fd.cFileName) );
+ }
+ } while (::FindNextFile(hFind, &fd));
+ ::FindClose(hFind);
+ #else
+ int n = optind;
+ while (n < m_argc) {
+- m_vFiles.push_back( fs::path(m_argv[n], fs::native) );
++ m_vFiles.push_back( fs::path(m_argv[n]) );
+ ++n;
+ }
+ #endif