summaryrefslogtreecommitdiff
path: root/media-gfx/scour/scour-0.37.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /media-gfx/scour/scour-0.37.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'media-gfx/scour/scour-0.37.ebuild')
-rw-r--r--media-gfx/scour/scour-0.37.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/scour/scour-0.37.ebuild b/media-gfx/scour/scour-0.37.ebuild
new file mode 100644
index 000000000000..8997eb6dcf04
--- /dev/null
+++ b/media-gfx/scour/scour-0.37.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Take an SVG file and produce a cleaner and more concise file"
+HOMEPAGE="https://github.com/scour-project/scour"
+SRC_URI="https://github.com/scour-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${EPYTHON}" testscour.py -v || die "Tests fail with ${EPYTHON}"
+}