summaryrefslogtreecommitdiff
path: root/media-gfx/sane-backends/sane-backends-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
commit1551fe56fd6ba43a94509cffc61b6bf854b7ac9f (patch)
treebe99b6ceb874878a108d68c641b476a2df076517 /media-gfx/sane-backends/sane-backends-1.2.1.ebuild
parent0e2a727aba684f1a44cc0402a3f77d242140681b (diff)
gentoo auto-resync : 01:06:2024 - 00:07:06
Diffstat (limited to 'media-gfx/sane-backends/sane-backends-1.2.1.ebuild')
-rw-r--r--media-gfx/sane-backends/sane-backends-1.2.1.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/media-gfx/sane-backends/sane-backends-1.2.1.ebuild b/media-gfx/sane-backends/sane-backends-1.2.1.ebuild
index 2b69e30c7d17..cec6801c00ca 100644
--- a/media-gfx/sane-backends/sane-backends-1.2.1.ebuild
+++ b/media-gfx/sane-backends/sane-backends-1.2.1.ebuild
@@ -3,11 +3,19 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
# python-any-r1 required for a script in backends/pixma/scripts/
inherit autotools flag-o-matic multilib-minimal optfeature python-any-r1 systemd toolchain-funcs udev
+DESCRIPTION="Scanner Access Now Easy - Backends"
+HOMEPAGE="http://www.sane-project.org/"
+SRC_URI="https://gitlab.com/sane-project/backends/uploads/110fc43336d0fb5e514f1fdc7360dd87/${P}.tar.gz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
# gphoto and v4l are handled by their usual USE flags.
# The pint backend was disabled because I could not get it to compile.
IUSE_SANE_BACKENDS=(
@@ -122,14 +130,6 @@ REQUIRED_USE="
sane_backends_mustek_usb2? ( threads )
"
-DESCRIPTION="Scanner Access Now Easy - Backends"
-HOMEPAGE="http://www.sane-project.org/"
-SRC_URI="https://gitlab.com/sane-project/backends/uploads/110fc43336d0fb5e514f1fdc7360dd87/${P}.tar.gz"
-
-LICENSE="GPL-2 public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
# For pixma: see https://gitlab.com/sane-project/backends/-/releases/1.0.28#build
RDEPEND="
acct-user/saned
@@ -164,13 +164,11 @@ RDEPEND="
xinetd? ( sys-apps/xinetd )
zeroconf? ( >=net-dns/avahi-0.6.31-r2[${MULTILIB_USEDEP}] )
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}
dev-libs/libxml2
v4l? ( sys-kernel/linux-headers )
"
-BDEPEND="
- ${PYTHON_DEPS}
+BDEPEND="${PYTHON_DEPS}
dev-build/autoconf-archive
sys-devel/gettext
virtual/pkgconfig