summaryrefslogtreecommitdiff
path: root/media-gfx/sam2p/sam2p-0.49.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/sam2p/sam2p-0.49.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/sam2p/sam2p-0.49.1.ebuild')
-rw-r--r--media-gfx/sam2p/sam2p-0.49.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/sam2p/sam2p-0.49.1.ebuild b/media-gfx/sam2p/sam2p-0.49.1.ebuild
new file mode 100644
index 000000000000..3ec3ab048c36
--- /dev/null
+++ b/media-gfx/sam2p/sam2p-0.49.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Utility to convert raster images to EPS, PDF and many others"
+HOMEPAGE="https://code.google.com/p/sam2p/"
+SRC_URI="https://sam2p.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples gif"
+
+RDEPEND=""
+DEPEND="dev-lang/perl"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.45-fbsd.patch \
+ "${FILESDIR}"/${PN}-0.49.1-build.patch \
+ "${FILESDIR}"/${PN}-0.49.1-gcc48.patch \
+ "${FILESDIR}"/${PN}-0.49-glibc-2.20.patch
+ eautoreconf
+ tc-export CXX
+}
+
+src_configure() {
+ econf --enable-lzw $(use_enable gif)
+}
+
+src_install() {
+ dobin sam2p
+ dodoc README
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}