summaryrefslogtreecommitdiff
path: root/media-gfx/ristretto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-10 13:27:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-10 13:27:24 +0100
commit0d7aefa5885e7552b4c2221df9f54e5930696228 (patch)
treeb7f05f240bfd3bc81f87edba206e78a8dc1a664b /media-gfx/ristretto
parent34d9839f7e484ac761071da50298470aa5ef5123 (diff)
gentoo auto-resync : 10:07:2022 - 13:27:24
Diffstat (limited to 'media-gfx/ristretto')
-rw-r--r--media-gfx/ristretto/Manifest2
-rw-r--r--media-gfx/ristretto/ristretto-0.12.3.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/ristretto/Manifest b/media-gfx/ristretto/Manifest
index 7dfa6fcd5a00..7f6f35e56f84 100644
--- a/media-gfx/ristretto/Manifest
+++ b/media-gfx/ristretto/Manifest
@@ -1,3 +1,5 @@
DIST ristretto-0.12.2.tar.bz2 612128 BLAKE2B d845da75f5139ca73702b2ea2154026ecadacc72587d81a22564d0c0ae84e605303a368ee42a9c915c3d00a0b8471f6a6e1a6c6c2f7d7626f766602a29022ee0 SHA512 39fc5868c3858e3667660b6411b3d39c19a2306be3d169e499aa11aff34a24e0ee8e745e15dfe301be48e1c6adce30129ed76270b025f5160cfa773467764379
+DIST ristretto-0.12.3.tar.bz2 616251 BLAKE2B 0f64918bae8511259acc90ce8851be0067ce635416fa908fde5a1e1fe9ae895b18cda06505c82cfae0aaf89fce41a56f80d5c2bcd4ad6cd3e93a95ef5cfb9037 SHA512 c78ec55196fbf3bcb843b240faea1f7eb532bfdc519c125337ebb61d20ab8e01c818920c9ec1bdd97035f8b5ce9bcd2ffb338a91b8919ca48ab1010828a8d49d
EBUILD ristretto-0.12.2.ebuild 891 BLAKE2B 0a1ad5b7e052921e9f49504488e42ed4db81d275d1186df39c8717fc92cd57d3bcb875dd15a952d231f0d9b03fa70d7153c6b6a339d1c433ff01046167862b53 SHA512 7148b68f84c0a9c9c07605cc3763b13940eaaa56e703445ef179e2280fb340afec7343884987779e40a4c4f42ce4b38a50cc6d520d24e1f2408784000050eeb2
+EBUILD ristretto-0.12.3.ebuild 901 BLAKE2B afef4ea16caefcfa6bcf4a7ee7d90e248a83b01e2b38334ba1a162282cec3eade650fc3bba183cef732b5173461ff3d092629d24b9d7b3b838ab8504468c521c SHA512 539bf9d2e0428f5652163653be67b39496e6c9e0312939640214b13d45709ddd6bb42699f638eeb8e39e910c90db33cb1b032c9dd66f7610195aef2c5772cdc0
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/media-gfx/ristretto/ristretto-0.12.3.ebuild b/media-gfx/ristretto/ristretto-0.12.3.ebuild
new file mode 100644
index 000000000000..70f85279a0a5
--- /dev/null
+++ b/media-gfx/ristretto/ristretto-0.12.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A fast and lightweight picture viewer for Xfce"
+HOMEPAGE="https://docs.xfce.org/apps/ristretto/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.46:2
+ media-libs/libexif:0=
+ sys-apps/file
+ x11-libs/cairo:0
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11:0=
+ >=xfce-base/libxfce4ui-4.16:0=
+ >=xfce-base/libxfce4util-4.16:0=
+ >=xfce-base/xfconf-4.12.1:0=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}